Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 17 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
 
4
# Uncomment this to turn on verbose mode.
5
#export DH_VERBOSE=1
6
 
7
# set some variables
8
ICONDIR=usr/share/icons
9
SHAREDIR=usr/share/crystalcursors
10
WRAPPERDIR=etc/X11/cursors
11
 
6 magnus 12
build: build-indep
3 magnus 13
 
18 magnus 14
build-arch:
6 magnus 15
build-indep: build-stamp
16
build-stamp:
3 magnus 17
	dh_testdir
18
 
19
	$(MAKE)
20
 
21
	touch build-stamp
22
 
23
clean:
24
	dh_testdir
25
	dh_testroot
26
	rm -f build-stamp configure-stamp
27
 
6 magnus 28
	$(MAKE) clean
3 magnus 29
 
30
	dh_clean
31
 
6 magnus 32
install: build-indep
3 magnus 33
	dh_testdir
34
	dh_testroot
35
	dh_prep
36
	dh_installdirs
37
 
38
	# Add here commands to install the package into debian/crystalcursors.
6 magnus 39
	$(MAKE) install PREFIX=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
3 magnus 40
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type f -exec chmod 644 {} \;
41
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type d -exec chmod 755 {} \;
42
 
43
	# Don't overwrite system's default xcursor, just provide the directory
44
	rm -r $(CURDIR)/debian/crystalcursors/$(ICONDIR)/default/*
45
 
17 magnus 46
	# There are no left-hand "cross" cursors, so don't symlink to them:
47
	rm $(CURDIR)/debian/crystalcursors/$(ICONDIR)/crystal*left/cursors/plus
48
 
3 magnus 49
	# Find *.theme and copy 'em to wrapper-location (see #365072)
50
	# We have to change the Inherits line in (only) in the wrapper *.themes:
51
	#  1) find .themes
52
	#  2) remove lines with "Inherits" and save as tmp
53
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
54
	# -- I know this is tricky, but I have not yet found a more elegant way to make
55
	#    crystalcursors work with debian's update-alternative
8 magnus 56
	# In addition, add new symlinks that Qt 4 looks for
57
 
3 magnus 58
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
59
	for theme in crystal*; do \
60
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
61
	    echo "Inherits = $${theme}" >> tmp ; \
62
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
63
	    rm tmp; \
8 magnus 64
	    while read target link; do \
65
	        if [ -e $$theme/cursors/$$target ]; then ln -sf $$target $$theme/cursors/$$link; fi; \
66
	    done < $(CURDIR)/debian/extra_symlinks;\
67
	done
3 magnus 68
 
6 magnus 69
binary-indep: build-indep install
3 magnus 70
	dh_testdir
71
	dh_testroot
72
	dh_installchangelogs CHANGELOG
73
	dh_installdocs
74
#	dh_install
75
	dh_compress
76
	dh_fixperms
77
	dh_installdeb
78
	dh_shlibdeps
79
	dh_gencontrol
80
	dh_md5sums
81
	dh_builddeb
82
 
6 magnus 83
binary-arch:
84
# No arch-dependent packages
3 magnus 85
 
6 magnus 86
binary: binary-indep
87
.PHONY: build-indep build clean binary-indep binary-arch binary install configure