Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 8 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
 
4
# Uncomment this to turn on verbose mode.
5
#export DH_VERBOSE=1
6
 
7
# set some variables
8
ICONDIR=usr/share/icons
9
SHAREDIR=usr/share/crystalcursors
10
WRAPPERDIR=etc/X11/cursors
11
 
6 magnus 12
build: build-indep
3 magnus 13
 
6 magnus 14
build-indep: build-stamp
15
build-stamp:
3 magnus 16
	dh_testdir
17
 
18
	$(MAKE)
19
 
20
	touch build-stamp
21
 
22
clean:
23
	dh_testdir
24
	dh_testroot
25
	rm -f build-stamp configure-stamp
26
 
6 magnus 27
	$(MAKE) clean
3 magnus 28
 
29
	dh_clean
30
 
6 magnus 31
install: build-indep
3 magnus 32
	dh_testdir
33
	dh_testroot
34
	dh_prep
35
	dh_installdirs
36
 
37
	# Add here commands to install the package into debian/crystalcursors.
6 magnus 38
	$(MAKE) install PREFIX=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
3 magnus 39
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type f -exec chmod 644 {} \;
40
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type d -exec chmod 755 {} \;
41
 
42
	# Don't overwrite system's default xcursor, just provide the directory
43
	rm -r $(CURDIR)/debian/crystalcursors/$(ICONDIR)/default/*
44
 
45
	# Find *.theme and copy 'em to wrapper-location (see #365072)
46
	# We have to change the Inherits line in (only) in the wrapper *.themes:
47
	#  1) find .themes
48
	#  2) remove lines with "Inherits" and save as tmp
49
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
50
	# -- I know this is tricky, but I have not yet found a more elegant way to make
51
	#    crystalcursors work with debian's update-alternative
52
	OLDDIR=`pwd` ;\
53
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
54
	for theme in crystal*; do \
55
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
56
	    echo "Inherits = $${theme}" >> tmp ; \
57
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
58
	    rm tmp; \
59
	done ; \
60
	cd $${OLDDIR}
61
 
6 magnus 62
binary-indep: build-indep install
3 magnus 63
	dh_testdir
64
	dh_testroot
65
	dh_installchangelogs CHANGELOG
66
	dh_installdocs
67
#	dh_install
68
	dh_compress
69
	dh_fixperms
70
	dh_installdeb
71
	dh_shlibdeps
72
	dh_gencontrol
73
	dh_md5sums
74
	dh_builddeb
75
 
6 magnus 76
binary-arch:
77
# No arch-dependent packages
3 magnus 78
 
6 magnus 79
binary: binary-indep
80
.PHONY: build-indep build clean binary-indep binary-arch binary install configure