Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 17 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 17 Rev 18
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
3
4
# Uncomment this to turn on verbose mode.
4
# Uncomment this to turn on verbose mode.
5
#export DH_VERBOSE=1
5
#export DH_VERBOSE=1
6
6
7
# set some variables
7
# set some variables
8
ICONDIR=usr/share/icons
8
ICONDIR=usr/share/icons
9
SHAREDIR=usr/share/crystalcursors
9
SHAREDIR=usr/share/crystalcursors
10
WRAPPERDIR=etc/X11/cursors
10
WRAPPERDIR=etc/X11/cursors
11
11
12
build: build-indep
12
build: build-indep
13
13
-
 
14
build-arch:
14
build-indep: build-stamp
15
build-indep: build-stamp
15
build-stamp:
16
build-stamp:
16
	dh_testdir
17
	dh_testdir
17
18
18
	$(MAKE)
19
	$(MAKE)
19
20
20
	touch build-stamp
21
	touch build-stamp
21
22
22
clean:
23
clean:
23
	dh_testdir
24
	dh_testdir
24
	dh_testroot
25
	dh_testroot
25
	rm -f build-stamp configure-stamp
26
	rm -f build-stamp configure-stamp
26
27
27
	$(MAKE) clean
28
	$(MAKE) clean
28
29
29
	dh_clean 
30
	dh_clean 
30
31
31
install: build-indep
32
install: build-indep
32
	dh_testdir
33
	dh_testdir
33
	dh_testroot
34
	dh_testroot
34
	dh_prep
35
	dh_prep
35
	dh_installdirs
36
	dh_installdirs
36
37
37
	# Add here commands to install the package into debian/crystalcursors.
38
	# Add here commands to install the package into debian/crystalcursors.
38
	$(MAKE) install PREFIX=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
39
	$(MAKE) install PREFIX=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
39
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type f -exec chmod 644 {} \;
40
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type f -exec chmod 644 {} \;
40
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type d -exec chmod 755 {} \;
41
	find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type d -exec chmod 755 {} \;
41
42
42
	# Don't overwrite system's default xcursor, just provide the directory
43
	# Don't overwrite system's default xcursor, just provide the directory
43
	rm -r $(CURDIR)/debian/crystalcursors/$(ICONDIR)/default/*
44
	rm -r $(CURDIR)/debian/crystalcursors/$(ICONDIR)/default/*
44
45
45
	# There are no left-hand "cross" cursors, so don't symlink to them:
46
	# There are no left-hand "cross" cursors, so don't symlink to them:
46
	rm $(CURDIR)/debian/crystalcursors/$(ICONDIR)/crystal*left/cursors/plus
47
	rm $(CURDIR)/debian/crystalcursors/$(ICONDIR)/crystal*left/cursors/plus
47
48
48
	# Find *.theme and copy 'em to wrapper-location (see #365072)
49
	# Find *.theme and copy 'em to wrapper-location (see #365072)
49
	# We have to change the Inherits line in (only) in the wrapper *.themes:
50
	# We have to change the Inherits line in (only) in the wrapper *.themes:
50
	#  1) find .themes
51
	#  1) find .themes
51
	#  2) remove lines with "Inherits" and save as tmp
52
	#  2) remove lines with "Inherits" and save as tmp
52
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
53
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
53
	# -- I know this is tricky, but I have not yet found a more elegant way to make
54
	# -- I know this is tricky, but I have not yet found a more elegant way to make
54
	#    crystalcursors work with debian's update-alternative 
55
	#    crystalcursors work with debian's update-alternative 
55
	# In addition, add new symlinks that Qt 4 looks for
56
	# In addition, add new symlinks that Qt 4 looks for
56
57
57
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
58
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
58
	for theme in crystal*; do \
59
	for theme in crystal*; do \
59
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
60
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
60
	    echo "Inherits = $${theme}" >> tmp ; \
61
	    echo "Inherits = $${theme}" >> tmp ; \
61
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
62
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
62
	    rm tmp; \
63
	    rm tmp; \
63
	    while read target link; do \
64
	    while read target link; do \
64
	        if [ -e $$theme/cursors/$$target ]; then ln -sf $$target $$theme/cursors/$$link; fi; \
65
	        if [ -e $$theme/cursors/$$target ]; then ln -sf $$target $$theme/cursors/$$link; fi; \
65
	    done < $(CURDIR)/debian/extra_symlinks;\
66
	    done < $(CURDIR)/debian/extra_symlinks;\
66
	done
67
	done
67
68
68
binary-indep: build-indep install
69
binary-indep: build-indep install
69
	dh_testdir
70
	dh_testdir
70
	dh_testroot
71
	dh_testroot
71
	dh_installchangelogs CHANGELOG
72
	dh_installchangelogs CHANGELOG
72
	dh_installdocs
73
	dh_installdocs
73
#	dh_install
74
#	dh_install
74
	dh_compress
75
	dh_compress
75
	dh_fixperms
76
	dh_fixperms
76
	dh_installdeb
77
	dh_installdeb
77
	dh_shlibdeps
78
	dh_shlibdeps
78
	dh_gencontrol
79
	dh_gencontrol
79
	dh_md5sums
80
	dh_md5sums
80
	dh_builddeb
81
	dh_builddeb
81
82
82
binary-arch:
83
binary-arch:
83
# No arch-dependent packages
84
# No arch-dependent packages
84
85
85
binary: binary-indep
86
binary: binary-indep
86
.PHONY: build-indep build clean binary-indep binary-arch binary install configure
87
.PHONY: build-indep build clean binary-indep binary-arch binary install configure