Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 6 | Rev 17 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 6 Rev 8
Line 47... Line 47...
47
	#  1) find .themes
47
	#  1) find .themes
48
	#  2) remove lines with "Inherits" and save as tmp
48
	#  2) remove lines with "Inherits" and save as tmp
49
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
49
	#  3) write new Inherits-line with name of the directory in /usr/share/icons
50
	# -- I know this is tricky, but I have not yet found a more elegant way to make
50
	# -- I know this is tricky, but I have not yet found a more elegant way to make
51
	#    crystalcursors work with debian's update-alternative 
51
	#    crystalcursors work with debian's update-alternative 
52
	OLDDIR=`pwd` ;\
52
	# In addition, add new symlinks that Qt 4 looks for
-
 
53
53
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
54
	cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
54
	for theme in crystal*; do \
55
	for theme in crystal*; do \
55
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
56
	    grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
56
	    echo "Inherits = $${theme}" >> tmp ; \
57
	    echo "Inherits = $${theme}" >> tmp ; \
57
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
58
	    install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
58
	    rm tmp; \
59
	    rm tmp; \
-
 
60
	    while read target link; do \
-
 
61
	        if [ -e $$theme/cursors/$$target ]; then ln -sf $$target $$theme/cursors/$$link; fi; \
-
 
62
	    done < $(CURDIR)/debian/extra_symlinks;\
59
	done ; \
63
	done
60
	cd $${OLDDIR}
-
 
61
64
62
binary-indep: build-indep install
65
binary-indep: build-indep install
63
	dh_testdir
66
	dh_testdir
64
	dh_testroot
67
	dh_testroot
65
	dh_installchangelogs CHANGELOG
68
	dh_installchangelogs CHANGELOG