Subversion Repositories crystalcursors

Compare Revisions

Ignore whitespace Rev 5 → Rev 6

/trunk/debian/rules
9,30 → 9,13
SHAREDIR=usr/share/crystalcursors
WRAPPERDIR=etc/X11/cursors
 
CFLAGS = -Wall -g
build: build-indep
 
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
 
configure: configure-stamp
configure-stamp:
build-indep: build-stamp
build-stamp:
dh_testdir
# Add here commands to configure the package.
 
touch configure-stamp
 
 
build: build-stamp
 
build-stamp: configure-stamp
dh_testdir
 
# Add here commands to compile the package.
$(MAKE)
#docbook-to-man debian/crystalcursors.sgml > crystalcursors.1
 
touch build-stamp
 
41,12 → 24,11
dh_testroot
rm -f build-stamp configure-stamp
 
# Add here commands to clean up after the build process.
[ ! Makefile ] || $(MAKE) clean
$(MAKE) clean
 
dh_clean
 
install: build
install: build-indep
dh_testdir
dh_testroot
dh_prep
53,7 → 35,7
dh_installdirs
 
# Add here commands to install the package into debian/crystalcursors.
$(MAKE) install DESTDIR=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
$(MAKE) install PREFIX=$(CURDIR)/debian/crystalcursors/$(ICONDIR)
find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type f -exec chmod 644 {} \;
find $(CURDIR)/debian/crystalcursors/$(ICONDIR) -type d -exec chmod 755 {} \;
 
77,31 → 59,14
done ; \
cd $${OLDDIR}
 
# Build architecture-independent files here.
binary-indep: build install
binary-indep: build-indep install
dh_testdir
dh_testroot
dh_installchangelogs CHANGELOG
dh_installdocs
# dh_installexamples
# dh_install
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installcron
# dh_installinfo
# dh_installman
# dh_link
# dh_strip
dh_compress
dh_fixperms
# dh_perl
# dh_python
# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
108,8 → 73,8
dh_md5sums
dh_builddeb
 
# Build architecture-dependent files here.
binary-arch: build install
binary-arch:
# No arch-dependent packages
 
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
binary: binary-indep
.PHONY: build-indep build clean binary-indep binary-arch binary install configure