Subversion Repositories crystalcursors

Compare Revisions

Ignore whitespace Rev 7 → Rev 8

/trunk/debian/rules
49,7 → 49,8
# 3) write new Inherits-line with name of the directory in /usr/share/icons
# -- I know this is tricky, but I have not yet found a more elegant way to make
# crystalcursors work with debian's update-alternative
OLDDIR=`pwd` ;\
# In addition, add new symlinks that Qt 4 looks for
 
cd $(CURDIR)/debian/crystalcursors/$(ICONDIR); \
for theme in crystal*; do \
grep -v Inherits $(CURDIR)/debian/crystalcursors/$(ICONDIR)/$${theme}/index.theme > tmp ; \
56,8 → 57,10
echo "Inherits = $${theme}" >> tmp ; \
install -m 644 tmp $(CURDIR)/debian/crystalcursors/$(WRAPPERDIR)/$${theme}.theme; \
rm tmp; \
done ; \
cd $${OLDDIR}
while read target link; do \
if [ -e $$theme/cursors/$$target ]; then ln -sf $$target $$theme/cursors/$$link; fi; \
done < $(CURDIR)/debian/extra_symlinks;\
done
 
binary-indep: build-indep install
dh_testdir