Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
1 | magnus | 1 | #! /usr/bin/make -f |
2 | |||
3 | # TODO: Switch to CDBS |
||
4 | # |
||
5 | # TODO: Auto-generate DebPool::Config (with pod2man, options: |
||
6 | # --section=5 --name="DebPool::Config" --center="DebPool Configuration") |
||
7 | |||
8 | build: |
||
9 | dh_testdir |
||
10 | |||
11 | binary-arch: |
||
12 | @echo "No arch-dependant files to build" |
||
13 | |||
14 | binary-indep: build |
||
15 | dh_testdir |
||
16 | dh_testroot |
||
17 | |||
18 | dh_installdirs -i |
||
19 | dh_install -i |
||
20 | dh_installdocs -i |
||
21 | dh_installexamples -i |
||
22 | dh_installchangelogs -i |
||
23 | dh_installman -i |
||
24 | |||
25 | dh_perl -i |
||
26 | |||
27 | dh_compress -i |
||
28 | dh_fixperms -i |
||
29 | |||
30 | dh_md5sums -i |
||
31 | dh_gencontrol -i |
||
32 | dh_installdeb -i |
||
33 | dh_builddeb -i |
||
34 | |||
35 | binary: binary-indep |
||
36 | |||
37 | clean: |
||
38 | dh_testdir |
||
39 | dh_testroot |
||
40 | |||
41 | dh_clean |
||
42 | |||
43 | .PHONY: binary binary-arch binary-indep build clean |