Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 1 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 1 Rev 5
1
#! /usr/bin/make -f
1
#! /usr/bin/make -f
2
2
3
# TODO: Switch to CDBS
3
# TODO: Switch to CDBS
4
#
4
#
5
# TODO: Auto-generate DebPool::Config (with pod2man, options:
5
# TODO: Auto-generate DebPool::Config (with pod2man, options:
6
# --section=5 --name="DebPool::Config" --center="DebPool Configuration")
6
# --section=5 --name="DebPool::Config" --center="DebPool Configuration")
7
7
8
build:
8
build:
9
	dh_testdir
9
	dh_testdir
10
10
11
binary-arch:
11
binary-arch:
12
	@echo "No arch-dependant files to build"
12
	@echo "No arch-dependant files to build"
13
13
14
binary-indep: build
14
binary-indep: build
15
	dh_testdir
15
	dh_testdir
16
	dh_testroot
16
	dh_testroot
17
17
18
	dh_installdirs -i
18
	dh_installdirs -i
19
	dh_install -i
19
	dh_install -i
20
	dh_installdocs -i
20
	dh_installdocs -i
21
	dh_installexamples -i
21
	dh_installexamples -i
22
	dh_installchangelogs -i
22
	dh_installchangelogs -i
23
	dh_installman -i
23
	dh_installman -i
24
24
25
	dh_perl -i
25
	dh_perl -i
26
26
27
	dh_compress -i
27
	dh_compress -i
28
	dh_fixperms -i
28
	dh_fixperms -i
29
29
30
	dh_md5sums -i
30
	dh_md5sums -i
31
	dh_gencontrol -i
31
	dh_gencontrol -i
32
	dh_installdeb -i
32
	dh_installdeb -i
33
	dh_builddeb -i
33
	dh_builddeb -i
34
34
35
binary: binary-indep
35
binary: binary-indep
36
36
37
clean:
37
clean:
38
	dh_testdir
38
	dh_testdir
39
	dh_testroot
39
	dh_testroot
40
40
41
	dh_clean
41
	dh_clean
42
42
43
.PHONY: binary binary-arch binary-indep build clean
43
.PHONY: binary binary-arch binary-indep build clean