Rev 2 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 20_winmacros.dpatch by Magnus Holmgren <magnus@kibibyte.se> |
||
3 | ## |
||
4 | ## DP: Define some macros that are used despite being Windows-specific |
||
5 | |||
6 | @DPATCH@ |
||
7 | |||
8 | --- libdkim-1.0.14.orig/src/dkim.h |
||
9 | +++ libdkim-1.0.14/src/dkim.h |
||
10 | @@ -18,7 +18,12 @@ |
||
11 | #ifdef WIN32 |
||
12 | #define DKIM_CALL WINAPI |
||
13 | #else |
||
14 | +#include <inttypes.h> |
||
15 | #define DKIM_CALL |
||
16 | +#define MAKELONG(low,high) \ |
||
17 | + ((uint32_t)(((uint16_t)(low))|((uint32_t)(((uint16_t)(high))<<16)))) |
||
18 | +#define HIWORD(l) ((uint16_t) (((uint32_t) (l) >> 16) & 0xFFFF)) |
||
19 | +#define LOWORD(l) ((uint16_t) (l)) |
||
20 | #endif |
||
21 | |||
22 |