Rev 2 | Blame | Compare with Previous | Last modification | View Log | RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 20_winmacros.dpatch by Magnus Holmgren <magnus@kibibyte.se>
##
## DP: Define some macros that are used despite being Windows-specific
@DPATCH@
--- libdkim-1.0.14.orig/src/dkim.h
+++ libdkim-1.0.14/src/dkim.h
@@ -18,7 +18,12 @@
#ifdef WIN32
#define DKIM_CALL WINAPI
#else
+#include <inttypes.h>
#define DKIM_CALL
+#define MAKELONG(low,high) \
+ ((uint32_t)(((uint16_t)(low))|((uint32_t)(((uint16_t)(high))<<16))))
+#define HIWORD(l) ((uint16_t) (((uint32_t) (l) >> 16) & 0xFFFF))
+#define LOWORD(l) ((uint16_t) (l))
#endif