Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
5 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 30_extra_fields.dpatch by Tom Kistner <tom@duncanthrax.net> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Add Domain and IdentityDomain fields to struct DKIMVerifyDetails. |
||
6 | |||
7 | @DPATCH@ |
||
8 | |||
9 | diff -w -xdebian -ur libdkim-1.0.14/src/dkim.h libdkim-1.0.15-tk/src/dkim.h |
||
10 | --- libdkim-1.0.14/src/dkim.h 2007-05-03 17:53:09.000000000 +0200 |
||
11 | +++ libdkim-1.0.15-tk/src/dkim.h 2007-09-28 13:08:04.000000000 +0200 |
||
12 | @@ -137,6 +137,8 @@ |
||
13 | { |
||
14 | char *szSignature; |
||
15 | char *DNS; |
||
16 | + char *Domain; |
||
17 | + char *IdentityDomain; |
||
18 | int nResult; |
||
19 | } DKIMVerifyDetails; |
||
20 | |||
21 | diff -w -xdebian -ur libdkim-1.0.14/src/dkimverify.cpp libdkim-1.0.15-tk/src/dkimverify.cpp |
||
22 | --- libdkim-1.0.14/src/dkimverify.cpp 2007-04-24 11:01:58.000000000 +0200 |
||
23 | +++ libdkim-1.0.15-tk/src/dkimverify.cpp 2007-09-28 08:05:01.000000000 +0200 |
||
24 | @@ -1428,6 +1386,10 @@ |
||
25 | DKIMVerifyDetails d; |
||
26 | d.szSignature = (char*)i->Header.c_str(); |
||
27 | d.nResult = i->Status; |
||
28 | + |
||
29 | + d.Domain = (char*)i->Domain.c_str(); |
||
30 | + d.IdentityDomain = i->IdentityDomain.empty()?(char*)i->IdentityDomain.c_str():(char*)i->Domain.c_str(); |
||
31 | + |
||
32 | Details.push_back(d); |
||
33 | } |
||
34 |