Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 5 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#! /bin/sh /usr/share/dpatch/dpatch-run
## 30_extra_fields.dpatch by Tom Kistner <tom@duncanthrax.net>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Add Domain and IdentityDomain fields to struct DKIMVerifyDetails.

@DPATCH@

diff -w -xdebian -ur libdkim-1.0.14/src/dkim.h libdkim-1.0.15-tk/src/dkim.h
--- libdkim-1.0.14/src/dkim.h   2007-05-03 17:53:09.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkim.h        2007-09-28 13:08:04.000000000 +0200
@@ -138,6 +138,8 @@
        char *szSignature;
        char *DNS;
        char *szCanonicalizedData;
+       char *Domain;
+       char *IdentityDomain;
        int nResult;
 } DKIMVerifyDetails;
 
diff -w -xdebian -ur libdkim-1.0.14/src/dkimverify.cpp libdkim-1.0.15-tk/src/dkimverify.cpp
--- libdkim-1.0.14/src/dkimverify.cpp   2007-04-24 11:01:58.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkimverify.cpp        2007-09-28 08:05:01.000000000 +0200
@@ -1508,6 +1508,10 @@
                d.szSignature = (char*)i->Header.c_str();
                d.nResult = i->Status;
                d.szCanonicalizedData = (char*)i->CanonicalizedData.c_str();
+
+               d.Domain = (char*)i->Domain.c_str();
+               d.IdentityDomain = i->IdentityDomain.empty()?(char*)i->IdentityDomain.c_str():(char*)i->Domain.c_str();
+
                Details.push_back(d);
        }