Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 5 | Blame | Compare with Previous | Last modification | View Log | RSS feed

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

include /usr/share/dpatch/dpatch.make

export CXXFLAGS = -Wall -g

ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CXXFLAGS += -O0
else
        CXXFLAGS += -O2
endif

configure: config.status
config.status: $(DPATCH_STAMPFN) debian/configure.ac
        dh_testdir
        ln -sf $(CURDIR)/debian/*.in src/
        cd debian && autoconf
        debian/configure --srcdir=src/ --prefix=/usr

build: build-stamp
build-stamp: config.status
        dh_testdir

        $(MAKE)

        touch $@

clean: clean-patched unpatch
clean-patched:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp

        [ ! -f Makefile ] || $(MAKE) distclean

        rm -f src/*.in debian/configure
        rm -rf debian/autom4te.cache
        dh_clean

install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
        dh_installdirs

        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
#       


# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
        dh_testdir
        dh_testroot
        dh_install --sourcedir=debian/tmp
        dh_link
        dh_installchangelogs -k README
        dh_installdocs
        dh_installexamples
#       dh_installinfo
#       dh_installman
        dh_strip
        dh_compress
        dh_fixperms
#       The shlibs dependency is intentionally made tight, because we have an 
#       experimental extension that may not be there in the next official release.
        dh_makeshlibs -V "libdkim1 (= `dpkg-parsechangelog | sed -ne 's/Version: *//p'`)"
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb

binary: binary-indep binary-arch
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure