Rev 18 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 18 | Rev 22 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # This file was originally written by Joey Hess and Craig Small. |
4 | # This file was originally written by Joey Hess and Craig Small. |
5 | # As a special exception, when this file is copied by dh-make into a |
5 | # As a special exception, when this file is copied by dh-make into a |
6 | # dh-make output file, you may use that output file without restriction. |
6 | # dh-make output file, you may use that output file without restriction. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
8 | 8 | ||
9 | # Uncomment this to turn on verbose mode. |
9 | # Uncomment this to turn on verbose mode. |
10 | #export DH_VERBOSE=1 |
10 | #export DH_VERBOSE=1 |
11 | 11 | ||
12 | include /usr/share/dpatch/dpatch.make |
12 | include /usr/share/dpatch/dpatch.make |
13 | 13 | ||
14 | export CXXFLAGS = -Wall -g |
14 | export CXXFLAGS = -Wall -g |
15 | 15 | ||
16 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
16 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
17 | CXXFLAGS += -O0 |
17 | CXXFLAGS += -O0 |
18 | else |
18 | else |
19 | CXXFLAGS += -O2 |
19 | CXXFLAGS += -O2 |
20 | endif |
20 | endif |
21 | 21 | ||
22 | configure: config.status |
22 | configure: Makefile |
23 | config.status: $(DPATCH_STAMPFN) debian/configure.ac |
23 | Makefile: $(DPATCH_STAMPFN) debian/pmkfile |
24 | dh_testdir |
24 | dh_testdir |
25 | ln -sf $(CURDIR)/debian/*.in src/ |
25 | ln -sf $(CURDIR)/debian/libdkim.pc.in src/libdkim.pc.pmk |
26 | cd debian && autoconf |
26 | pmk -f debian/pmkfile |
27 | debian/configure --srcdir=src/ --prefix=/usr |
- | |
28 | 27 | ||
29 | build: build-stamp |
28 | build: build-stamp |
30 | build-stamp: config.status |
29 | build-stamp: configure |
31 | dh_testdir |
30 | dh_testdir |
32 | 31 | ||
33 | $(MAKE) |
32 | (cd src && $(MAKE) -f ../Makefile) |
34 | 33 | ||
35 | touch $@ |
34 | touch $@ |
36 | 35 | ||
37 | clean: clean-patched unpatch |
36 | clean: clean-patched unpatch |
38 | clean-patched: |
37 | clean-patched: |
39 | dh_testdir |
38 | dh_testdir |
40 | dh_testroot |
39 | dh_testroot |
41 | rm -f build-stamp configure-stamp |
40 | rm -f build-stamp configure-stamp |
42 | 41 | ||
43 | [ ! -f Makefile ] || $(MAKE) distclean |
42 | [ ! -f Makefile ] || (cd src && $(MAKE) -f ../Makefile distclean) |
44 | 43 | ||
45 | rm -f src/*.in debian/configure |
44 | rm -f src/*.in debian/configure |
46 | rm -rf debian/autom4te.cache |
45 | rm -rf debian/autom4te.cache |
47 | dh_clean |
46 | dh_clean |
48 | 47 | ||
49 | install: build |
48 | install: build |
50 | dh_testdir |
49 | dh_testdir |
51 | dh_testroot |
50 | dh_testroot |
52 | dh_clean -k |
51 | dh_clean -k |
53 | dh_installdirs |
52 | dh_installdirs |
54 | 53 | ||
55 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
54 | (cd src && $(MAKE) -f ../Makefile install DESTDIR=$(CURDIR)/debian/tmp) |
56 | # |
55 | # |
57 | 56 | ||
58 | 57 | ||
59 | # Build architecture-independent files here. |
58 | # Build architecture-independent files here. |
60 | binary-indep: build install |
59 | binary-indep: build install |
61 | # We have nothing to do by default. |
60 | # We have nothing to do by default. |
62 | 61 | ||
63 | # Build architecture-dependent files here. |
62 | # Build architecture-dependent files here. |
64 | binary-arch: build install |
63 | binary-arch: build install |
65 | dh_testdir |
64 | dh_testdir |
66 | dh_testroot |
65 | dh_testroot |
67 | dh_install --sourcedir=debian/tmp |
66 | dh_install --sourcedir=debian/tmp |
68 | dh_link |
67 | dh_link |
69 | dh_installchangelogs -k README |
68 | dh_installchangelogs -k README |
70 | dh_installdocs |
69 | dh_installdocs |
71 | dh_installexamples |
70 | dh_installexamples |
72 | # dh_installinfo |
71 | # dh_installinfo |
73 | # dh_installman |
72 | # dh_installman |
74 | dh_strip |
73 | dh_strip |
75 | dh_compress |
74 | dh_compress |
76 | dh_fixperms |
75 | dh_fixperms |
77 | dh_makeshlibs |
76 | dh_makeshlibs |
78 | dh_installdeb |
77 | dh_installdeb |
79 | dh_shlibdeps |
78 | dh_shlibdeps |
80 | dh_gencontrol |
79 | dh_gencontrol |
81 | dh_md5sums |
80 | dh_md5sums |
82 | dh_builddeb |
81 | dh_builddeb |
83 | 82 | ||
84 | binary: binary-indep binary-arch |
83 | binary: binary-indep binary-arch |
85 | .PHONY: patch unpatch build clean binary-indep binary-arch binary install configure |
84 | .PHONY: patch unpatch build clean binary-indep binary-arch binary install configure |