Rev 18 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
||
3 | # Sample debian/rules that uses debhelper. |
||
4 | # This file was originally written by Joey Hess and Craig Small. |
||
5 | # As a special exception, when this file is copied by dh-make into a |
||
6 | # dh-make output file, you may use that output file without restriction. |
||
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
||
8 | |||
9 | # Uncomment this to turn on verbose mode. |
||
10 | #export DH_VERBOSE=1 |
||
11 | |||
12 | include /usr/share/dpatch/dpatch.make |
||
13 | |||
14 | export CXXFLAGS = -Wall -g |
||
15 | |||
16 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
||
17 | CXXFLAGS += -O0 |
||
18 | else |
||
19 | CXXFLAGS += -O2 |
||
20 | endif |
||
21 | |||
22 | magnus | 22 | configure: Makefile |
23 | Makefile: $(DPATCH_STAMPFN) debian/pmkfile |
||
2 | magnus | 24 | dh_testdir |
22 | magnus | 25 | ln -sf $(CURDIR)/debian/libdkim.pc.in src/libdkim.pc.pmk |
26 | pmk -f debian/pmkfile |
||
2 | magnus | 27 | |
28 | build: build-stamp |
||
22 | magnus | 29 | build-stamp: configure |
2 | magnus | 30 | dh_testdir |
31 | |||
22 | magnus | 32 | (cd src && $(MAKE) -f ../Makefile) |
2 | magnus | 33 | |
34 | touch $@ |
||
35 | |||
36 | clean: clean-patched unpatch |
||
37 | clean-patched: |
||
38 | dh_testdir |
||
39 | dh_testroot |
||
40 | rm -f build-stamp configure-stamp |
||
41 | |||
22 | magnus | 42 | [ ! -f Makefile ] || (cd src && $(MAKE) -f ../Makefile distclean) |
2 | magnus | 43 | |
44 | rm -f src/*.in debian/configure |
||
45 | rm -rf debian/autom4te.cache |
||
46 | dh_clean |
||
47 | |||
48 | install: build |
||
49 | dh_testdir |
||
50 | dh_testroot |
||
51 | dh_clean -k |
||
52 | dh_installdirs |
||
53 | |||
22 | magnus | 54 | (cd src && $(MAKE) -f ../Makefile install DESTDIR=$(CURDIR)/debian/tmp) |
2 | magnus | 55 | # |
56 | |||
57 | |||
58 | # Build architecture-independent files here. |
||
59 | binary-indep: build install |
||
60 | # We have nothing to do by default. |
||
61 | |||
62 | # Build architecture-dependent files here. |
||
63 | binary-arch: build install |
||
64 | dh_testdir |
||
65 | dh_testroot |
||
9 | magnus | 66 | dh_install --sourcedir=debian/tmp |
67 | dh_link |
||
68 | dh_installchangelogs -k README |
||
69 | dh_installdocs |
||
2 | magnus | 70 | dh_installexamples |
71 | # dh_installinfo |
||
72 | # dh_installman |
||
73 | dh_strip |
||
74 | dh_compress |
||
75 | dh_fixperms |
||
76 | dh_makeshlibs |
||
77 | dh_installdeb |
||
78 | dh_shlibdeps |
||
79 | dh_gencontrol |
||
80 | dh_md5sums |
||
81 | dh_builddeb |
||
82 | |||
83 | binary: binary-indep binary-arch |
||
84 | .PHONY: patch unpatch build clean binary-indep binary-arch binary install configure |