Rev 18 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 18 | Rev 22 | ||
---|---|---|---|
Line 17... | Line 17... | ||
17 | CXXFLAGS += -O0 |
17 | CXXFLAGS += -O0 |
18 | else |
18 | else |
19 | CXXFLAGS += -O2 |
19 | CXXFLAGS += -O2 |
20 | endif |
20 | endif |
21 | 21 | ||
22 | configure: config.status |
22 | configure: Makefile |
23 | config.status: $(DPATCH_STAMPFN) debian/configure.ac |
23 | Makefile: $(DPATCH_STAMPFN) debian/pmkfile |
24 | dh_testdir |
24 | dh_testdir |
25 | ln -sf $(CURDIR)/debian/*.in src/ |
25 | ln -sf $(CURDIR)/debian/libdkim.pc.in src/libdkim.pc.pmk |
26 | cd debian && autoconf |
26 | pmk -f debian/pmkfile |
27 | debian/configure --srcdir=src/ --prefix=/usr |
- | |
28 | 27 | ||
29 | build: build-stamp |
28 | build: build-stamp |
30 | build-stamp: config.status |
29 | build-stamp: configure |
31 | dh_testdir |
30 | dh_testdir |
32 | 31 | ||
33 | $(MAKE) |
32 | (cd src && $(MAKE) -f ../Makefile) |
34 | 33 | ||
35 | touch $@ |
34 | touch $@ |
36 | 35 | ||
37 | clean: clean-patched unpatch |
36 | clean: clean-patched unpatch |
38 | clean-patched: |
37 | clean-patched: |
39 | dh_testdir |
38 | dh_testdir |
40 | dh_testroot |
39 | dh_testroot |
41 | rm -f build-stamp configure-stamp |
40 | rm -f build-stamp configure-stamp |
42 | 41 | ||
43 | [ ! -f Makefile ] || $(MAKE) distclean |
42 | [ ! -f Makefile ] || (cd src && $(MAKE) -f ../Makefile distclean) |
44 | 43 | ||
45 | rm -f src/*.in debian/configure |
44 | rm -f src/*.in debian/configure |
46 | rm -rf debian/autom4te.cache |
45 | rm -rf debian/autom4te.cache |
47 | dh_clean |
46 | dh_clean |
48 | 47 | ||
Line 50... | Line 49... | ||
50 | dh_testdir |
49 | dh_testdir |
51 | dh_testroot |
50 | dh_testroot |
52 | dh_clean -k |
51 | dh_clean -k |
53 | dh_installdirs |
52 | dh_installdirs |
54 | 53 | ||
55 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
54 | (cd src && $(MAKE) -f ../Makefile install DESTDIR=$(CURDIR)/debian/tmp) |
56 | # |
55 | # |
57 | 56 | ||
58 | 57 | ||
59 | # Build architecture-independent files here. |
58 | # Build architecture-independent files here. |
60 | binary-indep: build install |
59 | binary-indep: build install |