Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 13 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
12 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
13 magnus 2
## 20_strict_includes.dpatch by Magnus Holmgren <magnus@kibibyte.se>
12 magnus 3
##
4
## All lines beginning with `## DP:' are a description of the patch.
13 magnus 5
## DP: Add "#include <string.h>" as needed to fix FTBFS with GCC 4.3.
12 magnus 6
 
7
@DPATCH@
8
diff -urNad trunk~/src/dkim.cpp trunk/src/dkim.cpp
9
--- trunk~/src/dkim.cpp	2007-09-04 14:38:44.000000000 +0200
10
+++ trunk/src/dkim.cpp	2008-01-19 23:32:38.000000000 +0100
11
@@ -20,6 +20,7 @@
12
 #else
13
 #endif
14
 
15
+#include <string.h>
16
 #include "dkim.h"
17
 #include "dkimsign.h"
18
 #include "dkimverify.h"
19
diff -urNad trunk~/src/dkimverify.cpp trunk/src/dkimverify.cpp
20
--- trunk~/src/dkimverify.cpp	2007-10-29 15:15:18.000000000 +0100
21
+++ trunk/src/dkimverify.cpp	2008-01-19 23:32:50.000000000 +0100
22
@@ -29,6 +29,7 @@
23
 #include <assert.h>
24
 #include <vector>
25
 #include <algorithm>
26
+#include <string.h>
27
 
28
 #define MAX_SIGNATURES	10			// maximum number of DKIM signatures to process in a message
29