Rev 47 | Rev 51 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 47 | Rev 50 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # This file was originally written by Joey Hess and Craig Small. |
4 | # This file was originally written by Joey Hess and Craig Small. |
5 | # As a special exception, when this file is copied by dh-make into a |
5 | # As a special exception, when this file is copied by dh-make into a |
6 | # dh-make output file, you may use that output file without restriction. |
6 | # dh-make output file, you may use that output file without restriction. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
8 | 8 | ||
9 | # Uncomment this to turn on verbose mode. |
9 | # Uncomment this to turn on verbose mode. |
10 | #export DH_VERBOSE=1 |
10 | #export DH_VERBOSE=1 |
11 | 11 | ||
12 | include /usr/share/dpatch/dpatch.make |
- | |
13 | - | ||
14 | export CXXFLAGS = -Wall -g |
12 | export CXXFLAGS = -Wall -g |
15 | 13 | ||
16 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
14 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
17 | CXXFLAGS += -O0 |
15 | CXXFLAGS += -O0 |
18 | else |
16 | else |
19 | CXXFLAGS += -O2 |
17 | CXXFLAGS += -O2 |
20 | endif |
18 | endif |
21 | 19 | ||
22 | configure: config.status |
20 | configure: config.status |
23 | config.status: $(DPATCH_STAMPFN) debian/configure.ac |
21 | config.status: debian/configure.ac |
24 | dh_testdir |
22 | dh_testdir |
25 | ln -sf $(CURDIR)/debian/*.in src/ |
23 | ln -sf $(CURDIR)/debian/*.in src/ |
26 | cd debian && autoconf |
24 | cd debian && autoconf |
27 | debian/configure --srcdir=src/ --prefix=/usr |
25 | debian/configure --srcdir=src/ --prefix=/usr |
28 | 26 | ||
29 | build: build-stamp |
27 | build: build-stamp |
30 | build-stamp: config.status |
28 | build-stamp: config.status |
31 | dh_testdir |
29 | dh_testdir |
32 | 30 | ||
33 | $(MAKE) |
31 | $(MAKE) |
34 | 32 | ||
35 | touch $@ |
33 | touch $@ |
36 | 34 | ||
37 | clean: clean-patched unpatch |
- | |
38 | clean-patched: |
35 | clean: |
39 | dh_testdir |
36 | dh_testdir |
40 | dh_testroot |
37 | dh_testroot |
41 | rm -f build-stamp configure-stamp |
38 | rm -f build-stamp configure-stamp |
42 | 39 | ||
43 | [ ! -f Makefile ] || $(MAKE) distclean |
40 | [ ! -f Makefile ] || $(MAKE) distclean |
44 | 41 | ||
45 | rm -f src/*.in debian/configure |
42 | rm -f src/*.in debian/configure |
46 | rm -rf debian/autom4te.cache |
43 | rm -rf debian/autom4te.cache |
47 | dh_clean |
44 | dh_clean |
48 | 45 | ||
49 | install: build |
46 | install: build |
50 | dh_testdir |
47 | dh_testdir |
51 | dh_testroot |
48 | dh_testroot |
52 | dh_clean -k |
49 | dh_clean -k |
53 | dh_installdirs |
50 | dh_installdirs |
54 | 51 | ||
55 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
52 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
56 | # |
53 | # |
57 | 54 | ||
58 | 55 | ||
59 | # Build architecture-independent files here. |
56 | # Build architecture-independent files here. |
60 | binary-indep: build install |
57 | binary-indep: build install |
61 | # We have nothing to do by default. |
58 | # We have nothing to do by default. |
62 | 59 | ||
63 | # Build architecture-dependent files here. |
60 | # Build architecture-dependent files here. |
64 | binary-arch: build install |
61 | binary-arch: build install |
65 | dh_testdir |
62 | dh_testdir |
66 | dh_testroot |
63 | dh_testroot |
67 | dh_install --sourcedir=debian/tmp |
64 | dh_install --sourcedir=debian/tmp |
68 | dh_link |
65 | dh_link |
69 | dh_installchangelogs -k README |
66 | dh_installchangelogs -k README |
70 | dh_installdocs |
67 | dh_installdocs |
71 | dh_installexamples |
68 | dh_installexamples |
72 | # dh_installinfo |
69 | # dh_installinfo |
73 | # dh_installman |
70 | # dh_installman |
74 | dh_strip --dbg-package=libdkim1d-dbg |
71 | dh_strip --dbg-package=libdkim1d-dbg |
75 | dh_compress |
72 | dh_compress |
76 | dh_fixperms |
73 | dh_fixperms |
77 | dh_makeshlibs |
74 | dh_makeshlibs |
78 | dh_installdeb |
75 | dh_installdeb |
79 | dh_shlibdeps |
76 | dh_shlibdeps |
80 | dh_gencontrol |
77 | dh_gencontrol |
81 | dh_md5sums |
78 | dh_md5sums |
82 | dh_builddeb |
79 | dh_builddeb |
83 | 80 | ||
84 | binary: binary-indep binary-arch |
81 | binary: binary-indep binary-arch |
85 | .PHONY: patch unpatch build clean binary-indep binary-arch binary install configure |
82 | .PHONY: patch unpatch build clean binary-indep binary-arch binary install configure |