Rev 58 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 58 | Rev 59 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # -*- makefile -*- |
2 | # -*- makefile -*- |
3 | # Sample debian/rules that uses debhelper. |
3 | # Sample debian/rules that uses debhelper. |
4 | # This file was originally written by Joey Hess and Craig Small. |
4 | # This file was originally written by Joey Hess and Craig Small. |
5 | # As a special exception, when this file is copied by dh-make into a |
5 | # As a special exception, when this file is copied by dh-make into a |
6 | # dh-make output file, you may use that output file without restriction. |
6 | # dh-make output file, you may use that output file without restriction. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
8 | 8 | ||
9 | # Uncomment this to turn on verbose mode. |
9 | # Uncomment this to turn on verbose mode. |
10 | #export DH_VERBOSE=1 |
10 | #export DH_VERBOSE=1 |
11 | 11 | ||
12 | export CXXFLAGS = -Wall -g |
- | |
13 | - | ||
14 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
- | |
15 | CXXFLAGS += -O0 |
- | |
16 | else |
- | |
17 | CXXFLAGS += -O2 |
- | |
18 | endif |
- | |
19 | - | ||
20 | configure: config.status |
12 | configure: config.status |
21 | config.status: debian/configure.ac |
13 | config.status: debian/configure.ac |
22 | dh_testdir |
14 | dh_testdir |
23 | ln -sf $(CURDIR)/debian/*.in src/ |
15 | ln -sf $(CURDIR)/debian/*.in src/ |
24 | cd debian && autoconf |
16 | cd debian && autoconf |
25 | debian/configure --srcdir=src/ --prefix=/usr |
17 | debian/configure --srcdir=src/ --prefix=/usr $(shell dpkg-buildflags --export=configure) |
26 | 18 | ||
27 | build-indep: |
19 | build-indep: |
28 | # Nothing to do |
20 | # Nothing to do |
29 | build-arch: build-stamp |
21 | build-arch: build-stamp |
30 | build-stamp: config.status |
22 | build-stamp: config.status |
31 | dh_testdir |
23 | dh_testdir |
32 | 24 | ||
33 | $(MAKE) |
25 | $(MAKE) |
34 | 26 | ||
35 | touch $@ |
27 | touch $@ |
36 | 28 | ||
37 | build: build-arch build-indep |
29 | build: build-arch build-indep |
38 | 30 | ||
39 | clean: |
31 | clean: |
40 | dh_testdir |
32 | dh_testdir |
41 | dh_testroot |
33 | dh_testroot |
42 | rm -f build-stamp configure-stamp |
34 | rm -f build-stamp configure-stamp |
43 | 35 | ||
44 | [ ! -f Makefile ] || $(MAKE) distclean |
36 | [ ! -f Makefile ] || $(MAKE) distclean |
45 | 37 | ||
46 | rm -f src/*.in debian/configure |
38 | rm -f src/*.in debian/configure |
47 | rm -rf debian/autom4te.cache |
39 | rm -rf debian/autom4te.cache |
48 | dh_clean |
40 | dh_clean |
49 | 41 | ||
50 | install: build |
42 | install: build |
51 | dh_testdir |
43 | dh_testdir |
52 | dh_testroot |
44 | dh_testroot |
53 | dh_prep |
45 | dh_prep |
54 | dh_installdirs |
46 | dh_installdirs |
55 | 47 | ||
56 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
48 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
57 | # |
49 | # |
58 | 50 | ||
59 | 51 | ||
60 | # Build architecture-independent files here. |
52 | # Build architecture-independent files here. |
61 | binary-indep: build-indep |
53 | binary-indep: build-indep |
62 | # Nothing to do |
54 | # Nothing to do |
63 | 55 | ||
64 | # Build architecture-dependent files here. |
56 | # Build architecture-dependent files here. |
65 | binary-arch: build-arch install |
57 | binary-arch: build-arch install |
66 | dh_testdir |
58 | dh_testdir |
67 | dh_testroot |
59 | dh_testroot |
68 | dh_install --sourcedir=debian/tmp |
60 | dh_install --sourcedir=debian/tmp |
69 | dh_link |
61 | dh_link |
70 | dh_installchangelogs -k README |
62 | dh_installchangelogs -k README |
71 | dh_installdocs |
63 | dh_installdocs |
72 | dh_installexamples |
64 | dh_installexamples |
73 | # dh_installinfo |
65 | # dh_installinfo |
74 | # dh_installman |
66 | # dh_installman |
75 | dh_strip --dbg-package=libdkim1d-dbg |
67 | dh_strip --dbg-package=libdkim1d-dbg |
76 | dh_compress |
68 | dh_compress |
77 | dh_fixperms |
69 | dh_fixperms |
78 | dh_makeshlibs |
70 | dh_makeshlibs |
79 | dh_installdeb |
71 | dh_installdeb |
80 | dh_shlibdeps |
72 | dh_shlibdeps |
81 | dh_gencontrol |
73 | dh_gencontrol |
82 | dh_md5sums |
74 | dh_md5sums |
83 | dh_builddeb |
75 | dh_builddeb |
84 | 76 | ||
85 | binary: binary-indep binary-arch |
77 | binary: binary-indep binary-arch |
86 | .PHONY: patch unpatch build-indep build-arch build clean binary-indep binary-arch binary install configure |
78 | .PHONY: patch unpatch build-indep build-arch build clean binary-indep binary-arch binary install configure |