Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 9 | Rev 39 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
include /usr/share/dpatch/dpatch.make
13
 
14
export CXXFLAGS = -Wall -g
15
 
16
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17
	CXXFLAGS += -O0
18
else
19
	CXXFLAGS += -O2
20
endif
21
 
22
configure: config.status
23
config.status: $(DPATCH_STAMPFN) debian/configure.ac
24
	dh_testdir
25
	ln -sf $(CURDIR)/debian/*.in src/
26
	cd debian && autoconf
27
	debian/configure --srcdir=src/ --prefix=/usr
28
 
29
build: build-stamp
30
build-stamp: config.status
31
	dh_testdir
32
 
33
	$(MAKE)
34
 
35
	touch $@
36
 
37
clean: clean-patched unpatch
38
clean-patched:
39
	dh_testdir
40
	dh_testroot
41
	rm -f build-stamp configure-stamp
42
 
18 magnus 43
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 44
 
45
	rm -f src/*.in debian/configure
46
	rm -rf debian/autom4te.cache
47
	dh_clean
48
 
49
install: build
50
	dh_testdir
51
	dh_testroot
52
	dh_clean -k
53
	dh_installdirs
54
 
55
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
56
#
57
 
58
 
59
# Build architecture-independent files here.
60
binary-indep: build install
61
# We have nothing to do by default.
62
 
63
# Build architecture-dependent files here.
64
binary-arch: build install
65
	dh_testdir
66
	dh_testroot
9 magnus 67
	dh_install --sourcedir=debian/tmp
68
	dh_link
69
	dh_installchangelogs -k README
70
	dh_installdocs
2 magnus 71
	dh_installexamples
72
#	dh_installinfo
73
#	dh_installman
74
	dh_strip
75
	dh_compress
76
	dh_fixperms
77
	dh_makeshlibs
78
	dh_installdeb
79
	dh_shlibdeps
80
	dh_gencontrol
81
	dh_md5sums
82
	dh_builddeb
83
 
84
binary: binary-indep binary-arch
85
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure