Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 50 | Rev 58 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
export CXXFLAGS = -Wall -g
13
 
45 magnus 14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
2 magnus 15
	CXXFLAGS += -O0
16
else
17
	CXXFLAGS += -O2
18
endif
19
 
20
configure: config.status
50 magnus 21
config.status: debian/configure.ac
2 magnus 22
	dh_testdir
23
	ln -sf $(CURDIR)/debian/*.in src/
24
	cd debian && autoconf
25
	debian/configure --srcdir=src/ --prefix=/usr
26
 
27
build: build-stamp
28
build-stamp: config.status
29
	dh_testdir
30
 
31
	$(MAKE)
32
 
33
	touch $@
34
 
50 magnus 35
clean:
2 magnus 36
	dh_testdir
37
	dh_testroot
38
	rm -f build-stamp configure-stamp
39
 
18 magnus 40
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 41
 
42
	rm -f src/*.in debian/configure
43
	rm -rf debian/autom4te.cache
44
	dh_clean
45
 
46
install: build
47
	dh_testdir
48
	dh_testroot
51 magnus 49
	dh_prep
2 magnus 50
	dh_installdirs
51
 
52
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
53
#
54
 
55
 
56
# Build architecture-independent files here.
57
binary-indep: build install
58
# We have nothing to do by default.
59
 
60
# Build architecture-dependent files here.
61
binary-arch: build install
62
	dh_testdir
63
	dh_testroot
9 magnus 64
	dh_install --sourcedir=debian/tmp
65
	dh_link
66
	dh_installchangelogs -k README
67
	dh_installdocs
2 magnus 68
	dh_installexamples
69
#	dh_installinfo
70
#	dh_installman
47 magnus 71
	dh_strip --dbg-package=libdkim1d-dbg
2 magnus 72
	dh_compress
73
	dh_fixperms
74
	dh_makeshlibs
75
	dh_installdeb
76
	dh_shlibdeps
77
	dh_gencontrol
78
	dh_md5sums
79
	dh_builddeb
80
 
81
binary: binary-indep binary-arch
82
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure