Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 51 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
export CXXFLAGS = -Wall -g
13
 
45 magnus 14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
2 magnus 15
	CXXFLAGS += -O0
16
else
17
	CXXFLAGS += -O2
18
endif
19
 
20
configure: config.status
50 magnus 21
config.status: debian/configure.ac
2 magnus 22
	dh_testdir
23
	ln -sf $(CURDIR)/debian/*.in src/
24
	cd debian && autoconf
25
	debian/configure --srcdir=src/ --prefix=/usr
26
 
58 magnus 27
build-indep:
28
# Nothing to do
29
build-arch: build-stamp
2 magnus 30
build-stamp: config.status
31
	dh_testdir
32
 
33
	$(MAKE)
34
 
35
	touch $@
36
 
58 magnus 37
build: build-arch build-indep
38
 
50 magnus 39
clean:
2 magnus 40
	dh_testdir
41
	dh_testroot
42
	rm -f build-stamp configure-stamp
43
 
18 magnus 44
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 45
 
46
	rm -f src/*.in debian/configure
47
	rm -rf debian/autom4te.cache
48
	dh_clean
49
 
50
install: build
51
	dh_testdir
52
	dh_testroot
51 magnus 53
	dh_prep
2 magnus 54
	dh_installdirs
55
 
56
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
57
#
58
 
59
 
60
# Build architecture-independent files here.
58 magnus 61
binary-indep: build-indep
62
# Nothing to do
2 magnus 63
 
64
# Build architecture-dependent files here.
58 magnus 65
binary-arch: build-arch install
2 magnus 66
	dh_testdir
67
	dh_testroot
9 magnus 68
	dh_install --sourcedir=debian/tmp
69
	dh_link
70
	dh_installchangelogs -k README
71
	dh_installdocs
2 magnus 72
	dh_installexamples
73
#	dh_installinfo
74
#	dh_installman
47 magnus 75
	dh_strip --dbg-package=libdkim1d-dbg
2 magnus 76
	dh_compress
77
	dh_fixperms
78
	dh_makeshlibs
79
	dh_installdeb
80
	dh_shlibdeps
81
	dh_gencontrol
82
	dh_md5sums
83
	dh_builddeb
84
 
85
binary: binary-indep binary-arch
58 magnus 86
.PHONY: patch unpatch build-indep build-arch build clean binary-indep binary-arch binary install configure