Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
 
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
11
 
12
configure: config.status
50 magnus 13
config.status: debian/configure.ac
2 magnus 14
	dh_testdir
15
	ln -sf $(CURDIR)/debian/*.in src/
16
	cd debian && autoconf
59 magnus 17
	debian/configure --srcdir=src/ --prefix=/usr $(shell dpkg-buildflags --export=configure)
2 magnus 18
 
58 magnus 19
build-indep:
20
# Nothing to do
21
build-arch: build-stamp
2 magnus 22
build-stamp: config.status
23
	dh_testdir
24
 
25
	$(MAKE)
26
 
27
	touch $@
28
 
58 magnus 29
build: build-arch build-indep
30
 
50 magnus 31
clean:
2 magnus 32
	dh_testdir
33
	dh_testroot
34
	rm -f build-stamp configure-stamp
35
 
18 magnus 36
	[ ! -f Makefile ] || $(MAKE) distclean
2 magnus 37
 
38
	rm -f src/*.in debian/configure
39
	rm -rf debian/autom4te.cache
40
	dh_clean
41
 
42
install: build
43
	dh_testdir
44
	dh_testroot
51 magnus 45
	dh_prep
2 magnus 46
	dh_installdirs
47
 
48
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
49
#
50
 
51
 
52
# Build architecture-independent files here.
58 magnus 53
binary-indep: build-indep
54
# Nothing to do
2 magnus 55
 
56
# Build architecture-dependent files here.
58 magnus 57
binary-arch: build-arch install
2 magnus 58
	dh_testdir
59
	dh_testroot
9 magnus 60
	dh_install --sourcedir=debian/tmp
61
	dh_link
62
	dh_installchangelogs -k README
63
	dh_installdocs
2 magnus 64
	dh_installexamples
65
#	dh_installinfo
66
#	dh_installman
47 magnus 67
	dh_strip --dbg-package=libdkim1d-dbg
2 magnus 68
	dh_compress
69
	dh_fixperms
70
	dh_makeshlibs
71
	dh_installdeb
72
	dh_shlibdeps
73
	dh_gencontrol
74
	dh_md5sums
75
	dh_builddeb
76
 
77
binary: binary-indep binary-arch
58 magnus 78
.PHONY: patch unpatch build-indep build-arch build clean binary-indep binary-arch binary install configure