Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 47 | Rev 51 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 47 Rev 50
Line 7... Line 7...
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
include /usr/share/dpatch/dpatch.make
-
 
13
-
 
14
export CXXFLAGS = -Wall -g
12
export CXXFLAGS = -Wall -g
15
13
16
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
17
	CXXFLAGS += -O0
15
	CXXFLAGS += -O0
18
else
16
else
19
	CXXFLAGS += -O2
17
	CXXFLAGS += -O2
20
endif
18
endif
21
19
22
configure: config.status
20
configure: config.status
23
config.status: $(DPATCH_STAMPFN) debian/configure.ac
21
config.status: debian/configure.ac
24
	dh_testdir
22
	dh_testdir
25
	ln -sf $(CURDIR)/debian/*.in src/
23
	ln -sf $(CURDIR)/debian/*.in src/
26
	cd debian && autoconf
24
	cd debian && autoconf
27
	debian/configure --srcdir=src/ --prefix=/usr
25
	debian/configure --srcdir=src/ --prefix=/usr
28
26
Line 32... Line 30...
32
30
33
	$(MAKE)
31
	$(MAKE)
34
32
35
	touch $@
33
	touch $@
36
34
37
clean: clean-patched unpatch
-
 
38
clean-patched:
35
clean:
39
	dh_testdir
36
	dh_testdir
40
	dh_testroot
37
	dh_testroot
41
	rm -f build-stamp configure-stamp
38
	rm -f build-stamp configure-stamp
42
39
43
	[ ! -f Makefile ] || $(MAKE) distclean
40
	[ ! -f Makefile ] || $(MAKE) distclean