Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 50 | Rev 58 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 50 Rev 51
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# -*- makefile -*-
2
# -*- makefile -*-
3
# Sample debian/rules that uses debhelper.
3
# Sample debian/rules that uses debhelper.
4
# This file was originally written by Joey Hess and Craig Small.
4
# This file was originally written by Joey Hess and Craig Small.
5
# As a special exception, when this file is copied by dh-make into a
5
# As a special exception, when this file is copied by dh-make into a
6
# dh-make output file, you may use that output file without restriction.
6
# dh-make output file, you may use that output file without restriction.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
export CXXFLAGS = -Wall -g
12
export CXXFLAGS = -Wall -g
13
13
14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
15
	CXXFLAGS += -O0
15
	CXXFLAGS += -O0
16
else
16
else
17
	CXXFLAGS += -O2
17
	CXXFLAGS += -O2
18
endif
18
endif
19
19
20
configure: config.status
20
configure: config.status
21
config.status: debian/configure.ac
21
config.status: debian/configure.ac
22
	dh_testdir
22
	dh_testdir
23
	ln -sf $(CURDIR)/debian/*.in src/
23
	ln -sf $(CURDIR)/debian/*.in src/
24
	cd debian && autoconf
24
	cd debian && autoconf
25
	debian/configure --srcdir=src/ --prefix=/usr
25
	debian/configure --srcdir=src/ --prefix=/usr
26
26
27
build: build-stamp
27
build: build-stamp
28
build-stamp: config.status
28
build-stamp: config.status
29
	dh_testdir
29
	dh_testdir
30
30
31
	$(MAKE)
31
	$(MAKE)
32
32
33
	touch $@
33
	touch $@
34
34
35
clean:
35
clean:
36
	dh_testdir
36
	dh_testdir
37
	dh_testroot
37
	dh_testroot
38
	rm -f build-stamp configure-stamp
38
	rm -f build-stamp configure-stamp
39
39
40
	[ ! -f Makefile ] || $(MAKE) distclean
40
	[ ! -f Makefile ] || $(MAKE) distclean
41
41
42
	rm -f src/*.in debian/configure
42
	rm -f src/*.in debian/configure
43
	rm -rf debian/autom4te.cache
43
	rm -rf debian/autom4te.cache
44
	dh_clean
44
	dh_clean
45
45
46
install: build
46
install: build
47
	dh_testdir
47
	dh_testdir
48
	dh_testroot
48
	dh_testroot
49
	dh_clean -k 
49
	dh_prep
50
	dh_installdirs
50
	dh_installdirs
51
51
52
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
52
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
53
#	
53
#	
54
54
55
55
56
# Build architecture-independent files here.
56
# Build architecture-independent files here.
57
binary-indep: build install
57
binary-indep: build install
58
# We have nothing to do by default.
58
# We have nothing to do by default.
59
59
60
# Build architecture-dependent files here.
60
# Build architecture-dependent files here.
61
binary-arch: build install
61
binary-arch: build install
62
	dh_testdir
62
	dh_testdir
63
	dh_testroot
63
	dh_testroot
64
	dh_install --sourcedir=debian/tmp
64
	dh_install --sourcedir=debian/tmp
65
	dh_link
65
	dh_link
66
	dh_installchangelogs -k README
66
	dh_installchangelogs -k README
67
	dh_installdocs
67
	dh_installdocs
68
	dh_installexamples
68
	dh_installexamples
69
#	dh_installinfo
69
#	dh_installinfo
70
#	dh_installman
70
#	dh_installman
71
	dh_strip --dbg-package=libdkim1d-dbg
71
	dh_strip --dbg-package=libdkim1d-dbg
72
	dh_compress
72
	dh_compress
73
	dh_fixperms
73
	dh_fixperms
74
	dh_makeshlibs
74
	dh_makeshlibs
75
	dh_installdeb
75
	dh_installdeb
76
	dh_shlibdeps
76
	dh_shlibdeps
77
	dh_gencontrol
77
	dh_gencontrol
78
	dh_md5sums
78
	dh_md5sums
79
	dh_builddeb
79
	dh_builddeb
80
80
81
binary: binary-indep binary-arch
81
binary: binary-indep binary-arch
82
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure
82
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure