Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 51 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 51 Rev 58
Line 22... Line 22...
22
	dh_testdir
22
	dh_testdir
23
	ln -sf $(CURDIR)/debian/*.in src/
23
	ln -sf $(CURDIR)/debian/*.in src/
24
	cd debian && autoconf
24
	cd debian && autoconf
25
	debian/configure --srcdir=src/ --prefix=/usr
25
	debian/configure --srcdir=src/ --prefix=/usr
26
26
-
 
27
build-indep:
-
 
28
# Nothing to do
27
build: build-stamp
29
build-arch: build-stamp
28
build-stamp: config.status
30
build-stamp: config.status
29
	dh_testdir
31
	dh_testdir
30
32
31
	$(MAKE)
33
	$(MAKE)
32
34
33
	touch $@
35
	touch $@
34
36
-
 
37
build: build-arch build-indep
-
 
38
35
clean:
39
clean:
36
	dh_testdir
40
	dh_testdir
37
	dh_testroot
41
	dh_testroot
38
	rm -f build-stamp configure-stamp
42
	rm -f build-stamp configure-stamp
39
43
Line 52... Line 56...
52
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
56
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
53
#	
57
#	
54
58
55
59
56
# Build architecture-independent files here.
60
# Build architecture-independent files here.
57
binary-indep: build install
61
binary-indep: build-indep
58
# We have nothing to do by default.
62
# Nothing to do
59
63
60
# Build architecture-dependent files here.
64
# Build architecture-dependent files here.
61
binary-arch: build install
65
binary-arch: build-arch install
62
	dh_testdir
66
	dh_testdir
63
	dh_testroot
67
	dh_testroot
64
	dh_install --sourcedir=debian/tmp
68
	dh_install --sourcedir=debian/tmp
65
	dh_link
69
	dh_link
66
	dh_installchangelogs -k README
70
	dh_installchangelogs -k README
Line 77... Line 81...
77
	dh_gencontrol
81
	dh_gencontrol
78
	dh_md5sums
82
	dh_md5sums
79
	dh_builddeb
83
	dh_builddeb
80
84
81
binary: binary-indep binary-arch
85
binary: binary-indep binary-arch
82
.PHONY: patch unpatch build clean binary-indep binary-arch binary install configure
86
.PHONY: patch unpatch build-indep build-arch build clean binary-indep binary-arch binary install configure