Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 58 Rev 59
Line 7... Line 7...
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
7
# This special exception was added by Craig Small in version 0.37 of dh-make.
8
8
9
# Uncomment this to turn on verbose mode.
9
# Uncomment this to turn on verbose mode.
10
#export DH_VERBOSE=1
10
#export DH_VERBOSE=1
11
11
12
export CXXFLAGS = -Wall -g
-
 
13
-
 
14
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
-
 
15
	CXXFLAGS += -O0
-
 
16
else
-
 
17
	CXXFLAGS += -O2
-
 
18
endif
-
 
19
-
 
20
configure: config.status
12
configure: config.status
21
config.status: debian/configure.ac
13
config.status: debian/configure.ac
22
	dh_testdir
14
	dh_testdir
23
	ln -sf $(CURDIR)/debian/*.in src/
15
	ln -sf $(CURDIR)/debian/*.in src/
24
	cd debian && autoconf
16
	cd debian && autoconf
25
	debian/configure --srcdir=src/ --prefix=/usr
17
	debian/configure --srcdir=src/ --prefix=/usr $(shell dpkg-buildflags --export=configure)
26
18
27
build-indep:
19
build-indep:
28
# Nothing to do
20
# Nothing to do
29
build-arch: build-stamp
21
build-arch: build-stamp
30
build-stamp: config.status
22
build-stamp: config.status