Subversion Repositories libdkim

Compare Revisions

Ignore whitespace Rev 4 → Rev 5

/branches/exp-tk/debian/patches/00list
1,0 → 0,0
20_winmacros
30_extra_fields
/branches/exp-tk/debian/patches/30_extra_fields.dpatch
0,0 → 1,34
#! /bin/sh /usr/share/dpatch/dpatch-run
## 30_extra_fields.dpatch by Tom Kistner <tom@duncanthrax.net>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Add Domain and IdentityDomain fields to struct DKIMVerifyDetails.
 
@DPATCH@
 
diff -w -xdebian -ur libdkim-1.0.14/src/dkim.h libdkim-1.0.15-tk/src/dkim.h
--- libdkim-1.0.14/src/dkim.h 2007-05-03 17:53:09.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkim.h 2007-09-28 13:08:04.000000000 +0200
@@ -137,6 +137,8 @@
{
char *szSignature;
char *DNS;
+ char *Domain;
+ char *IdentityDomain;
int nResult;
} DKIMVerifyDetails;
diff -w -xdebian -ur libdkim-1.0.14/src/dkimverify.cpp libdkim-1.0.15-tk/src/dkimverify.cpp
--- libdkim-1.0.14/src/dkimverify.cpp 2007-04-24 11:01:58.000000000 +0200
+++ libdkim-1.0.15-tk/src/dkimverify.cpp 2007-09-28 08:05:01.000000000 +0200
@@ -1428,6 +1386,10 @@
DKIMVerifyDetails d;
d.szSignature = (char*)i->Header.c_str();
d.nResult = i->Status;
+
+ d.Domain = (char*)i->Domain.c_str();
+ d.IdentityDomain = i->IdentityDomain.empty()?(char*)i->IdentityDomain.c_str():(char*)i->Domain.c_str();
+
Details.push_back(d);
}