Subversion Repositories libdkim

Compare Revisions

Ignore whitespace Rev 46 → Rev 47

/trunk/debian/patches/fix_warnings.dpatch
275,17 → 275,6
{
if (values[j] != NULL && values[j] < values[0])
{
@@ -1411,8 +1411,8 @@
return DKIM_POLICY_DNS_PERM_FAILURE;
}
- unsigned pos = sDomain.find('.');
- if (pos == -1 || sDomain.find('.', pos+1) == -1)
+ string::size_type pos = sDomain.find('.');
+ if (pos == string::npos || sDomain.find('.', pos+1) == string::npos)
{
// SSP not found but the domain exists, it's non-suspicious
iSSP = DKIM_SSP_UNKNOWN;
diff -ru libdkim-1.0.19.orig/src/libdkimtest.cpp libdkim-1.0.19/src/libdkimtest.cpp
--- libdkim-1.0.19.orig/src/libdkimtest.cpp 2008-05-12 20:08:54.000000000 +1000
+++ libdkim-1.0.19/src/libdkimtest.cpp 2009-04-15 19:38:08.000000000 +1000