Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 40 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
#-*- makefile -*-
3
# Made with the aid of dh_make, by Craig Small
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5
# Some lines taken from debmake, by Christoph Lameter.
6
 
7
# Uncomment this to turn on verbose mode.
8
#export DH_VERBOSE=1
9
 
10
PACKAGE := $(shell dh_listpackages)
11
 
12
PERL     = /usr/bin/perl
13
 
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
15
 
16
build: build-stamp
17
build-stamp:
18
	dh_testdir
19
 
20
	$(PERL) Makefile.PL INSTALLDIRS=vendor
21
	$(MAKE)
23 magnus 22
	-$(MAKE) test
2 magnus 23
	touch build-stamp
24
 
25
clean:
26
	dh_testdir
27
	dh_testroot
28
	rm -f build-stamp
29
 
20 magnus 30
	[ ! -f Makefile ] || $(MAKE) realclean
2 magnus 31
 
32
	dh_clean
33
 
40 magnus 34
install: build-stamp
2 magnus 35
	dh_testdir
36
	dh_testroot
37
	dh_clean -k
38
 
39
	$(MAKE) install DESTDIR=$(TMP)/
40 magnus 40
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
2 magnus 41
 
42
        # Remove any empty directories
43
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
44
 
45
# Build architecture-dependent files here.
46
binary-arch:
47
# We have nothing to do by default.
48
 
49
# Build architecture-independent files here.
40 magnus 50
binary-indep: install
2 magnus 51
	dh_testdir
52
	dh_testroot
53
	dh_installdocs
54
	dh_installchangelogs -k ChangeLog
55
	dh_link
27 magnus 56
	dh_compress
2 magnus 57
	dh_fixperms
58
	dh_installdeb
59
	dh_perl
60
	dh_gencontrol
61
	dh_md5sums
62
	dh_builddeb
63
 
64
binary: binary-indep
65
.PHONY: build clean binary-indep binary-arch binary