Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 58 Rev 61
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
#-*- makefile -*-
2
#-*- makefile -*-
3
# Made with the aid of dh_make, by Craig Small
3
# Made with the aid of dh_make, by Craig Small
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5
# Some lines taken from debmake, by Christoph Lameter.
5
# Some lines taken from debmake, by Christoph Lameter.
6
6
7
# Uncomment this to turn on verbose mode.
7
# Uncomment this to turn on verbose mode.
8
#export DH_VERBOSE=1
8
#export DH_VERBOSE=1
9
9
10
PACKAGE := $(shell dh_listpackages)
10
PACKAGE := $(shell dh_listpackages)
11
11
12
PERL     = /usr/bin/perl
12
PERL     = /usr/bin/perl
13
13
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
15
15
16
build-arch:
16
build-arch:
17
build-indep: build
17
build-indep: build
18
build: build-stamp
18
build: build-stamp
19
build-stamp:
19
build-stamp:
20
	dh_testdir
20
	dh_testdir
21
21
22
	$(PERL) Makefile.PL INSTALLDIRS=vendor
22
	$(PERL) Makefile.PL INSTALLDIRS=vendor
23
	$(MAKE)
23
	$(MAKE)
24
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
24
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
25
	-$(MAKE) test
25
	-$(MAKE) test
26
endif
26
endif
27
	touch build-stamp
27
	touch build-stamp
28
28
29
clean:
29
clean:
30
	dh_testdir
30
	dh_testdir
31
	dh_testroot
31
	dh_testroot
32
	rm -f build-stamp
32
	rm -f build-stamp
33
33
34
	[ ! -f Makefile ] || $(MAKE) realclean
34
	[ ! -f Makefile ] || $(MAKE) realclean
35
35
36
	dh_clean
36
	dh_clean
37
37
38
install: build-stamp
38
install: build-stamp
39
	dh_testdir
39
	dh_testdir
40
	dh_testroot
40
	dh_testroot
41
	dh_clean -k
41
	dh_clean -k
42
42
43
	$(MAKE) install DESTDIR=$(TMP)/
43
	$(MAKE) install DESTDIR=$(TMP)/
44
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
44
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
45
	install -d $(TMP)/usr/bin/
45
	install -d $(TMP)/usr/bin/
46
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
46
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
47
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
47
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
48
48
49
        # Remove any empty directories
49
        # Remove any empty directories
50
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
50
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
51
51
52
# Build architecture-dependent files here.
52
# Build architecture-dependent files here.
53
binary-arch:
53
binary-arch:
54
# We have nothing to do by default.
54
# We have nothing to do by default.
55
55
56
# Build architecture-independent files here.
56
# Build architecture-independent files here.
57
binary-indep: install
57
binary-indep: install
58
	dh_testdir
58
	dh_testdir
59
	dh_testroot
59
	dh_testroot
60
	dh_installman
60
	dh_installman
61
	dh_installdocs
61
	dh_installdocs
62
	dh_installchangelogs -k ChangeLog
62
	dh_installchangelogs -k ChangeLog
63
	dh_link
63
	dh_link
64
	dh_compress
64
	dh_compress
65
	dh_fixperms
65
	dh_fixperms
66
	dh_installdeb
66
	dh_installdeb
67
	dh_perl
67
	dh_perl
68
	dh_gencontrol
68
	dh_gencontrol
69
	dh_md5sums
69
	dh_md5sums
70
	dh_builddeb
70
	dh_builddeb
71
71
72
binary: binary-indep
72
binary: binary-indep
73
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary
73
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary