Rev 40 | Rev 47 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 40 | Rev 44 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | #-*- makefile -*- |
2 | #-*- makefile -*- |
3 | # Made with the aid of dh_make, by Craig Small |
3 | # Made with the aid of dh_make, by Craig Small |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
6 | 6 | ||
7 | # Uncomment this to turn on verbose mode. |
7 | # Uncomment this to turn on verbose mode. |
8 | #export DH_VERBOSE=1 |
8 | #export DH_VERBOSE=1 |
9 | 9 | ||
10 | PACKAGE := $(shell dh_listpackages) |
10 | PACKAGE := $(shell dh_listpackages) |
11 | 11 | ||
12 | PERL = /usr/bin/perl |
12 | PERL = /usr/bin/perl |
13 | 13 | ||
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
15 | 15 | ||
16 | build: build-stamp |
16 | build: build-stamp |
17 | build-stamp: |
17 | build-stamp: |
18 | dh_testdir |
18 | dh_testdir |
19 | 19 | ||
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
21 | $(MAKE) |
21 | $(MAKE) |
- | 22 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
|
22 | -$(MAKE) test |
23 | -$(MAKE) test |
- | 24 | endif |
|
23 | touch build-stamp |
25 | touch build-stamp |
24 | 26 | ||
25 | clean: |
27 | clean: |
26 | dh_testdir |
28 | dh_testdir |
27 | dh_testroot |
29 | dh_testroot |
28 | rm -f build-stamp |
30 | rm -f build-stamp |
29 | 31 | ||
30 | [ ! -f Makefile ] || $(MAKE) realclean |
32 | [ ! -f Makefile ] || $(MAKE) realclean |
31 | 33 | ||
32 | dh_clean |
34 | dh_clean |
33 | 35 | ||
34 | install: build-stamp |
36 | install: build-stamp |
35 | dh_testdir |
37 | dh_testdir |
36 | dh_testroot |
38 | dh_testroot |
37 | dh_clean -k |
39 | dh_clean -k |
38 | 40 | ||
39 | $(MAKE) install DESTDIR=$(TMP)/ |
41 | $(MAKE) install DESTDIR=$(TMP)/ |
40 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
42 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
41 | 43 | ||
42 | # Remove any empty directories |
44 | # Remove any empty directories |
43 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
45 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
44 | 46 | ||
45 | # Build architecture-dependent files here. |
47 | # Build architecture-dependent files here. |
46 | binary-arch: |
48 | binary-arch: |
47 | # We have nothing to do by default. |
49 | # We have nothing to do by default. |
48 | 50 | ||
49 | # Build architecture-independent files here. |
51 | # Build architecture-independent files here. |
50 | binary-indep: install |
52 | binary-indep: install |
51 | dh_testdir |
53 | dh_testdir |
52 | dh_testroot |
54 | dh_testroot |
53 | dh_installdocs |
55 | dh_installdocs |
54 | dh_installchangelogs -k ChangeLog |
56 | dh_installchangelogs -k ChangeLog |
55 | dh_link |
57 | dh_link |
56 | dh_compress |
58 | dh_compress |
57 | dh_fixperms |
59 | dh_fixperms |
58 | dh_installdeb |
60 | dh_installdeb |
59 | dh_perl |
61 | dh_perl |
60 | dh_gencontrol |
62 | dh_gencontrol |
61 | dh_md5sums |
63 | dh_md5sums |
62 | dh_builddeb |
64 | dh_builddeb |
63 | 65 | ||
64 | binary: binary-indep |
66 | binary: binary-indep |
65 | .PHONY: build clean binary-indep binary-arch binary |
67 | .PHONY: build clean binary-indep binary-arch binary |