Rev 27 | Rev 44 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 27 | Rev 40 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | #-*- makefile -*- |
2 | #-*- makefile -*- |
3 | # Made with the aid of dh_make, by Craig Small |
3 | # Made with the aid of dh_make, by Craig Small |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
6 | 6 | ||
7 | # Uncomment this to turn on verbose mode. |
7 | # Uncomment this to turn on verbose mode. |
8 | #export DH_VERBOSE=1 |
8 | #export DH_VERBOSE=1 |
9 | 9 | ||
10 | PACKAGE := $(shell dh_listpackages) |
10 | PACKAGE := $(shell dh_listpackages) |
11 | 11 | ||
12 | PERL = /usr/bin/perl |
12 | PERL = /usr/bin/perl |
13 | 13 | ||
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
15 | 15 | ||
16 | build: build-stamp |
16 | build: build-stamp |
17 | build-stamp: |
17 | build-stamp: |
18 | dh_testdir |
18 | dh_testdir |
19 | 19 | ||
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
21 | $(MAKE) |
21 | $(MAKE) |
22 | -$(MAKE) test |
22 | -$(MAKE) test |
23 | touch build-stamp |
23 | touch build-stamp |
24 | 24 | ||
25 | clean: |
25 | clean: |
26 | dh_testdir |
26 | dh_testdir |
27 | dh_testroot |
27 | dh_testroot |
28 | rm -f build-stamp |
28 | rm -f build-stamp |
29 | 29 | ||
30 | [ ! -f Makefile ] || $(MAKE) realclean |
30 | [ ! -f Makefile ] || $(MAKE) realclean |
31 | 31 | ||
32 | dh_clean |
32 | dh_clean |
33 | 33 | ||
34 | install: |
34 | install: build-stamp |
35 | dh_testdir |
35 | dh_testdir |
36 | dh_testroot |
36 | dh_testroot |
37 | dh_clean -k |
37 | dh_clean -k |
38 | dh_installdirs |
- | |
39 | 38 | ||
40 | $(MAKE) install DESTDIR=$(TMP)/ |
39 | $(MAKE) install DESTDIR=$(TMP)/ |
- | 40 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
|
41 | 41 | ||
42 | # Remove any empty directories |
42 | # Remove any empty directories |
43 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
43 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
44 | 44 | ||
45 | # Build architecture-dependent files here. |
45 | # Build architecture-dependent files here. |
46 | binary-arch: |
46 | binary-arch: |
47 | # We have nothing to do by default. |
47 | # We have nothing to do by default. |
48 | 48 | ||
49 | # Build architecture-independent files here. |
49 | # Build architecture-independent files here. |
50 | binary-indep: build install |
50 | binary-indep: install |
51 | dh_testdir |
51 | dh_testdir |
52 | dh_testroot |
52 | dh_testroot |
53 | dh_installdocs |
53 | dh_installdocs |
54 | dh_installman |
- | |
55 | dh_installchangelogs -k ChangeLog |
54 | dh_installchangelogs -k ChangeLog |
56 | dh_link |
55 | dh_link |
57 | dh_compress |
56 | dh_compress |
58 | dh_fixperms |
57 | dh_fixperms |
59 | dh_installdeb |
58 | dh_installdeb |
60 | dh_perl |
59 | dh_perl |
61 | dh_gencontrol |
60 | dh_gencontrol |
62 | dh_md5sums |
61 | dh_md5sums |
63 | dh_builddeb |
62 | dh_builddeb |
64 | 63 | ||
65 | binary: binary-indep |
64 | binary: binary-indep |
66 | .PHONY: build clean binary-indep binary-arch binary |
65 | .PHONY: build clean binary-indep binary-arch binary |