Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 47 | Rev 63 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 47 Rev 58
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
#-*- makefile -*-
2
#-*- makefile -*-
3
# Made with the aid of dh_make, by Craig Small
3
# Made with the aid of dh_make, by Craig Small
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5
# Some lines taken from debmake, by Christoph Lameter.
5
# Some lines taken from debmake, by Christoph Lameter.
6
6
7
# Uncomment this to turn on verbose mode.
7
# Uncomment this to turn on verbose mode.
8
#export DH_VERBOSE=1
8
#export DH_VERBOSE=1
9
9
10
PACKAGE := $(shell dh_listpackages)
10
PACKAGE := $(shell dh_listpackages)
11
11
12
PERL     = /usr/bin/perl
12
PERL     = /usr/bin/perl
13
13
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
15
15
-
 
16
build-arch:
-
 
17
build-indep: build
16
build: build-stamp
18
build: build-stamp
17
build-stamp:
19
build-stamp:
18
	dh_testdir
20
	dh_testdir
19
21
20
	$(PERL) Makefile.PL INSTALLDIRS=vendor
22
	$(PERL) Makefile.PL INSTALLDIRS=vendor
21
	$(MAKE)
23
	$(MAKE)
22
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
24
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
23
	-$(MAKE) test
25
	-$(MAKE) test
24
endif
26
endif
25
	touch build-stamp
27
	touch build-stamp
26
28
27
clean:
29
clean:
28
	dh_testdir
30
	dh_testdir
29
	dh_testroot
31
	dh_testroot
30
	rm -f build-stamp
32
	rm -f build-stamp
31
33
32
	[ ! -f Makefile ] || $(MAKE) realclean
34
	[ ! -f Makefile ] || $(MAKE) realclean
33
35
34
	dh_clean
36
	dh_clean
35
37
36
install: build-stamp
38
install: build-stamp
37
	dh_testdir
39
	dh_testdir
38
	dh_testroot
40
	dh_testroot
39
	dh_clean -k
41
	dh_clean -k
40
42
41
	$(MAKE) install DESTDIR=$(TMP)/
43
	$(MAKE) install DESTDIR=$(TMP)/
42
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
44
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
43
	install -d $(TMP)/usr/bin/
45
	install -d $(TMP)/usr/bin/
44
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
46
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
45
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
47
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
46
48
47
        # Remove any empty directories
49
        # Remove any empty directories
48
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
50
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
49
51
50
# Build architecture-dependent files here.
52
# Build architecture-dependent files here.
51
binary-arch:
53
binary-arch:
52
# We have nothing to do by default.
54
# We have nothing to do by default.
53
55
54
# Build architecture-independent files here.
56
# Build architecture-independent files here.
55
binary-indep: install
57
binary-indep: install
56
	dh_testdir
58
	dh_testdir
57
	dh_testroot
59
	dh_testroot
58
	dh_installman
60
	dh_installman
59
	dh_installdocs
61
	dh_installdocs
60
	dh_installchangelogs -k ChangeLog
62
	dh_installchangelogs -k ChangeLog
61
	dh_link
63
	dh_link
62
	dh_compress
64
	dh_compress
63
	dh_fixperms
65
	dh_fixperms
64
	dh_installdeb
66
	dh_installdeb
65
	dh_perl
67
	dh_perl
66
	dh_gencontrol
68
	dh_gencontrol
67
	dh_md5sums
69
	dh_md5sums
68
	dh_builddeb
70
	dh_builddeb
69
71
70
binary: binary-indep
72
binary: binary-indep
71
.PHONY: build clean binary-indep binary-arch binary
73
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary