Rev 44 | Rev 58 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 44 | Rev 47 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | #-*- makefile -*- |
2 | #-*- makefile -*- |
3 | # Made with the aid of dh_make, by Craig Small |
3 | # Made with the aid of dh_make, by Craig Small |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
5 | # Some lines taken from debmake, by Christoph Lameter. |
6 | 6 | ||
7 | # Uncomment this to turn on verbose mode. |
7 | # Uncomment this to turn on verbose mode. |
8 | #export DH_VERBOSE=1 |
8 | #export DH_VERBOSE=1 |
9 | 9 | ||
10 | PACKAGE := $(shell dh_listpackages) |
10 | PACKAGE := $(shell dh_listpackages) |
11 | 11 | ||
12 | PERL = /usr/bin/perl |
12 | PERL = /usr/bin/perl |
13 | 13 | ||
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
15 | 15 | ||
16 | build: build-stamp |
16 | build: build-stamp |
17 | build-stamp: |
17 | build-stamp: |
18 | dh_testdir |
18 | dh_testdir |
19 | 19 | ||
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
21 | $(MAKE) |
21 | $(MAKE) |
22 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
22 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
23 | -$(MAKE) test |
23 | -$(MAKE) test |
24 | endif |
24 | endif |
25 | touch build-stamp |
25 | touch build-stamp |
26 | 26 | ||
27 | clean: |
27 | clean: |
28 | dh_testdir |
28 | dh_testdir |
29 | dh_testroot |
29 | dh_testroot |
30 | rm -f build-stamp |
30 | rm -f build-stamp |
31 | 31 | ||
32 | [ ! -f Makefile ] || $(MAKE) realclean |
32 | [ ! -f Makefile ] || $(MAKE) realclean |
33 | 33 | ||
34 | dh_clean |
34 | dh_clean |
35 | 35 | ||
36 | install: build-stamp |
36 | install: build-stamp |
37 | dh_testdir |
37 | dh_testdir |
38 | dh_testroot |
38 | dh_testroot |
39 | dh_clean -k |
39 | dh_clean -k |
40 | 40 | ||
41 | $(MAKE) install DESTDIR=$(TMP)/ |
41 | $(MAKE) install DESTDIR=$(TMP)/ |
42 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
42 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
- | 43 | install -d $(TMP)/usr/bin/ |
|
- | 44 | install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign |
|
- | 45 | install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify |
|
43 | 46 | ||
44 | # Remove any empty directories |
47 | # Remove any empty directories |
45 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
48 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
46 | 49 | ||
47 | # Build architecture-dependent files here. |
50 | # Build architecture-dependent files here. |
48 | binary-arch: |
51 | binary-arch: |
49 | # We have nothing to do by default. |
52 | # We have nothing to do by default. |
50 | 53 | ||
51 | # Build architecture-independent files here. |
54 | # Build architecture-independent files here. |
52 | binary-indep: install |
55 | binary-indep: install |
53 | dh_testdir |
56 | dh_testdir |
54 | dh_testroot |
57 | dh_testroot |
- | 58 | dh_installman |
|
55 | dh_installdocs |
59 | dh_installdocs |
56 | dh_installchangelogs -k ChangeLog |
60 | dh_installchangelogs -k ChangeLog |
57 | dh_link |
61 | dh_link |
58 | dh_compress |
62 | dh_compress |
59 | dh_fixperms |
63 | dh_fixperms |
60 | dh_installdeb |
64 | dh_installdeb |
61 | dh_perl |
65 | dh_perl |
62 | dh_gencontrol |
66 | dh_gencontrol |
63 | dh_md5sums |
67 | dh_md5sums |
64 | dh_builddeb |
68 | dh_builddeb |
65 | 69 | ||
66 | binary: binary-indep |
70 | binary: binary-indep |
67 | .PHONY: build clean binary-indep binary-arch binary |
71 | .PHONY: build clean binary-indep binary-arch binary |