Rev 47 | Rev 63 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
2 | #-*- makefile -*- |
||
3 | # Made with the aid of dh_make, by Craig Small |
||
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
||
5 | # Some lines taken from debmake, by Christoph Lameter. |
||
6 | |||
7 | # Uncomment this to turn on verbose mode. |
||
8 | #export DH_VERBOSE=1 |
||
9 | |||
10 | PACKAGE := $(shell dh_listpackages) |
||
11 | |||
12 | PERL = /usr/bin/perl |
||
13 | |||
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
||
15 | |||
58 | magnus | 16 | build-arch: |
17 | build-indep: build |
||
2 | magnus | 18 | build: build-stamp |
19 | build-stamp: |
||
20 | dh_testdir |
||
21 | |||
22 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
||
23 | $(MAKE) |
||
44 | magnus | 24 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
23 | magnus | 25 | -$(MAKE) test |
44 | magnus | 26 | endif |
2 | magnus | 27 | touch build-stamp |
28 | |||
29 | clean: |
||
30 | dh_testdir |
||
31 | dh_testroot |
||
32 | rm -f build-stamp |
||
33 | |||
20 | magnus | 34 | [ ! -f Makefile ] || $(MAKE) realclean |
2 | magnus | 35 | |
36 | dh_clean |
||
37 | |||
40 | magnus | 38 | install: build-stamp |
2 | magnus | 39 | dh_testdir |
40 | dh_testroot |
||
41 | dh_clean -k |
||
42 | |||
43 | $(MAKE) install DESTDIR=$(TMP)/ |
||
40 | magnus | 44 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
47 | magnus | 45 | install -d $(TMP)/usr/bin/ |
46 | install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign |
||
47 | install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify |
||
2 | magnus | 48 | |
49 | # Remove any empty directories |
||
50 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
||
51 | |||
52 | # Build architecture-dependent files here. |
||
53 | binary-arch: |
||
54 | # We have nothing to do by default. |
||
55 | |||
56 | # Build architecture-independent files here. |
||
40 | magnus | 57 | binary-indep: install |
2 | magnus | 58 | dh_testdir |
59 | dh_testroot |
||
47 | magnus | 60 | dh_installman |
2 | magnus | 61 | dh_installdocs |
62 | dh_installchangelogs -k ChangeLog |
||
63 | dh_link |
||
27 | magnus | 64 | dh_compress |
2 | magnus | 65 | dh_fixperms |
66 | dh_installdeb |
||
67 | dh_perl |
||
68 | dh_gencontrol |
||
69 | dh_md5sums |
||
70 | dh_builddeb |
||
71 | |||
72 | binary: binary-indep |
||
58 | magnus | 73 | .PHONY: build build-arch build-indep clean binary-indep binary-arch binary |