Rev 40 | Rev 47 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #!/usr/bin/make -f |
2 | #-*- makefile -*- |
||
3 | # Made with the aid of dh_make, by Craig Small |
||
4 | # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess. |
||
5 | # Some lines taken from debmake, by Christoph Lameter. |
||
6 | |||
7 | # Uncomment this to turn on verbose mode. |
||
8 | #export DH_VERBOSE=1 |
||
9 | |||
10 | PACKAGE := $(shell dh_listpackages) |
||
11 | |||
12 | PERL = /usr/bin/perl |
||
13 | |||
14 | TMP := $(CURDIR)/debian/$(PACKAGE) |
||
15 | |||
16 | build: build-stamp |
||
17 | build-stamp: |
||
18 | dh_testdir |
||
19 | |||
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
||
21 | $(MAKE) |
||
44 | magnus | 22 | ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS))) |
23 | magnus | 23 | -$(MAKE) test |
44 | magnus | 24 | endif |
2 | magnus | 25 | touch build-stamp |
26 | |||
27 | clean: |
||
28 | dh_testdir |
||
29 | dh_testroot |
||
30 | rm -f build-stamp |
||
31 | |||
20 | magnus | 32 | [ ! -f Makefile ] || $(MAKE) realclean |
2 | magnus | 33 | |
34 | dh_clean |
||
35 | |||
40 | magnus | 36 | install: build-stamp |
2 | magnus | 37 | dh_testdir |
38 | dh_testroot |
||
39 | dh_clean -k |
||
40 | |||
41 | $(MAKE) install DESTDIR=$(TMP)/ |
||
40 | magnus | 42 | rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm |
2 | magnus | 43 | |
44 | # Remove any empty directories |
||
45 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
||
46 | |||
47 | # Build architecture-dependent files here. |
||
48 | binary-arch: |
||
49 | # We have nothing to do by default. |
||
50 | |||
51 | # Build architecture-independent files here. |
||
40 | magnus | 52 | binary-indep: install |
2 | magnus | 53 | dh_testdir |
54 | dh_testroot |
||
55 | dh_installdocs |
||
56 | dh_installchangelogs -k ChangeLog |
||
57 | dh_link |
||
27 | magnus | 58 | dh_compress |
2 | magnus | 59 | dh_fixperms |
60 | dh_installdeb |
||
61 | dh_perl |
||
62 | dh_gencontrol |
||
63 | dh_md5sums |
||
64 | dh_builddeb |
||
65 | |||
66 | binary: binary-indep |
||
67 | .PHONY: build clean binary-indep binary-arch binary |