Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 44 | Rev 63 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
#-*- makefile -*-
3
# Made with the aid of dh_make, by Craig Small
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5
# Some lines taken from debmake, by Christoph Lameter.
6
 
7
# Uncomment this to turn on verbose mode.
8
#export DH_VERBOSE=1
9
 
10
PACKAGE := $(shell dh_listpackages)
11
 
12
PERL     = /usr/bin/perl
13
 
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
15
 
16
build: build-stamp
17
build-stamp:
18
	dh_testdir
19
 
20
	$(PERL) Makefile.PL INSTALLDIRS=vendor
21
	$(MAKE)
44 magnus 22
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
23 magnus 23
	-$(MAKE) test
44 magnus 24
endif
2 magnus 25
	touch build-stamp
26
 
27
clean:
28
	dh_testdir
29
	dh_testroot
30
	rm -f build-stamp
31
 
20 magnus 32
	[ ! -f Makefile ] || $(MAKE) realclean
2 magnus 33
 
34
	dh_clean
35
 
40 magnus 36
install: build-stamp
2 magnus 37
	dh_testdir
38
	dh_testroot
39
	dh_clean -k
40
 
41
	$(MAKE) install DESTDIR=$(TMP)/
40 magnus 42
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
47 magnus 43
	install -d $(TMP)/usr/bin/
44
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
45
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
2 magnus 46
 
47
        # Remove any empty directories
48
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
49
 
50
# Build architecture-dependent files here.
51
binary-arch:
52
# We have nothing to do by default.
53
 
54
# Build architecture-independent files here.
40 magnus 55
binary-indep: install
2 magnus 56
	dh_testdir
57
	dh_testroot
47 magnus 58
	dh_installman
2 magnus 59
	dh_installdocs
60
	dh_installchangelogs -k ChangeLog
61
	dh_link
27 magnus 62
	dh_compress
2 magnus 63
	dh_fixperms
64
	dh_installdeb
65
	dh_perl
66
	dh_gencontrol
67
	dh_md5sums
68
	dh_builddeb
69
 
70
binary: binary-indep
71
.PHONY: build clean binary-indep binary-arch binary