Rev 20 | Rev 27 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 20 | Rev 23 | ||
---|---|---|---|
Line 17... | Line 17... | ||
17 | build-stamp: |
17 | build-stamp: |
18 | dh_testdir |
18 | dh_testdir |
19 | 19 | ||
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
20 | $(PERL) Makefile.PL INSTALLDIRS=vendor |
21 | $(MAKE) |
21 | $(MAKE) |
22 | $(MAKE) test || true |
22 | -$(MAKE) test |
23 | touch build-stamp |
23 | touch build-stamp |
24 | 24 | ||
25 | clean: |
25 | clean: |
26 | dh_testdir |
26 | dh_testdir |
27 | dh_testroot |
27 | dh_testroot |
Line 42... | Line 42... | ||
42 | # Remove any empty directories |
42 | # Remove any empty directories |
43 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
43 | find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';' |
44 | 44 | ||
45 | # Build architecture-dependent files here. |
45 | # Build architecture-dependent files here. |
46 | binary-arch: |
46 | binary-arch: |
47 | dh_testdir |
- | |
48 | touch debian/files |
- | |
49 | # We have nothing to do by default. |
47 | # We have nothing to do by default. |
50 | 48 | ||
51 | # Build architecture-independent files here. |
49 | # Build architecture-independent files here. |
52 | binary-indep: build install |
50 | binary-indep: build install |
53 | dh_testdir |
51 | dh_testdir |