Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 58 | Rev 74 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 58 Rev 63
Line 1... Line 1...
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
-
 
2
%:
2
#-*- makefile -*-
3
	dh $@
3
# Made with the aid of dh_make, by Craig Small
-
 
4
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-
 
5
# Some lines taken from debmake, by Christoph Lameter.
-
 
6
4
7
# Uncomment this to turn on verbose mode.
5
override_dh_auto_test:
8
#export DH_VERBOSE=1
6
	-dh_auto_test
9
7
10
PACKAGE := $(shell dh_listpackages)
-
 
11
-
 
12
PERL     = /usr/bin/perl
-
 
13
-
 
14
TMP     := $(CURDIR)/debian/$(PACKAGE)
8
TMP=$(CURDIR)/debian/libmail-dkim-perl
15
-
 
16
build-arch:
-
 
17
build-indep: build
-
 
18
build: build-stamp
9
override_dh_auto_install:
19
build-stamp:
-
 
20
	dh_testdir
-
 
21
-
 
22
	$(PERL) Makefile.PL INSTALLDIRS=vendor
-
 
23
	$(MAKE)
-
 
24
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-
 
25
	-$(MAKE) test
-
 
26
endif
-
 
27
	touch build-stamp
-
 
28
-
 
29
clean:
-
 
30
	dh_testdir
-
 
31
	dh_testroot
-
 
32
	rm -f build-stamp
-
 
33
-
 
34
	[ ! -f Makefile ] || $(MAKE) realclean
-
 
35
-
 
36
	dh_clean
-
 
37
-
 
38
install: build-stamp
-
 
39
	dh_testdir
10
	dh_auto_install
40
	dh_testroot
-
 
41
	dh_clean -k
-
 
42
-
 
43
	$(MAKE) install DESTDIR=$(TMP)/
-
 
44
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
11
	rm -f $(TMP)/usr/share/man/man3/Mail::DKIM::PublicKey.3pm
45
	install -d $(TMP)/usr/bin/
12
	install -d $(TMP)/usr/bin
46
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
13
	install scripts/dkimsign.pl $(TMP)/usr/bin/dkimproxy-sign
47
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
14
	install scripts/dkimverify.pl $(TMP)/usr/bin/dkimproxy-verify
48
15
49
        # Remove any empty directories
16
        # Remove any empty directories
50
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
17
	find $(TMP)/usr -depth -type d -empty -exec rmdir '{}' ';'
51
-
 
52
# Build architecture-dependent files here.
-
 
53
binary-arch:
-
 
54
# We have nothing to do by default.
-
 
55
-
 
56
# Build architecture-independent files here.
-
 
57
binary-indep: install
-
 
58
	dh_testdir
-
 
59
	dh_testroot
-
 
60
	dh_installman
-
 
61
	dh_installdocs
-
 
62
	dh_installchangelogs -k ChangeLog
-
 
63
	dh_link
-
 
64
	dh_compress
-
 
65
	dh_fixperms
-
 
66
	dh_installdeb
-
 
67
	dh_perl
-
 
68
	dh_gencontrol
-
 
69
	dh_md5sums
-
 
70
	dh_builddeb
-
 
71
-
 
72
binary: binary-indep
-
 
73
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary
-