Subversion Repositories

?revision_form?
Rev ?revision_input??revision_submit?
?revision_endform?

Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
57 1239d 13h magnus /trunk/debian/ Switch to Debhelper compat level 9.  
54 2243d 09h magnus /trunk/debian/ Bump Standards-Version to 3.9.5.  
51 2423d 09h magnus /trunk/debian/ Bump Standards-Version to 3.9.4.  
50 2423d 09h magnus /trunk/debian/ Check in debian/control too  
47 2423d 09h magnus /trunk/debian/ Update homepage URL.  
45 3020d 09h magnus /trunk/debian/ Bump Standards-Version to 3.9.3.  
44 3020d 09h magnus /trunk/debian/ Use current automake to build package, instead of 1.9, since it seems
to work. Maybe 1.10 didn't work.
 
42 3048d 09h magnus /trunk/debian/ * Add build-arch and build-indep targets.
* Remove arch-indep build dependency on sharutils, which is unnecessary
since the conversion to source format 3.0 when the former web site was
put in an additional upstream tarball.
* Use dpkg-buildflags.
* Use dh-autoreconf to handle autoreconfing.
 
40 3594d 00h magnus /trunk/debian/ Remove dependency on binutils-gold, which was inadvertently left in
place after testing.
 
38 3596d 14h magnus /trunk/debian/ explicit_linking.patch: In Makefile.am, explicitly link test-oop with
all the libraries that the adapter libraries use, so that the package
can be built with binutils-gold, where --no-add-needed is the default
(Closes: #555285). Also add -lglib-2.0 to the Libs: line in
liboop-glib2.pc (indirectly, via liboop-glib2.pc.in).
 
36 3596d 16h magnus /trunk/debian/ upstream tarball. This means the logo no longer has to be stored as-is
instead of as a self-extracting archive, making the associated
Makefile unnecessary as well. The html can be installed by
dh_installdocs instead.
* Upgrade to debhelper compatibility level 7, use dh_install instead
of dh_movefiles as well as dh_prep instead of dh_clean.
 
33 3664d 09h magnus /trunk/debian/ Add debug package  
31 3902d 11h magnus /trunk/debian/ Bump Standards-Version to 3.8.3.  
30 3902d 11h magnus /trunk/debian/ Remove libc6-dev from Depends of liboop-dev; it's build-essential.  
29 3902d 11h magnus /trunk/debian/ Add ${misc:Depends} to all Depends in case Debhelper needs it.  
28 3902d 11h magnus /trunk/debian/ Build with libreadline6 instead of libreadline5 (drop the
libreadline5-dev Build-Depends alternative).
 
25 4069d 12h magnus /trunk/debian/ Bump Standards-Version to 3.8.1.  
24 4069d 12h magnus /trunk/debian/ Switch to Debhelper level 5.  
23 4069d 13h magnus /trunk/debian/ Build with GLib 2.0 instead of 1.2 (Closes: #523688).  
21 4361d 19h magnus /trunk/debian/ Add Homepage field and watch file, and update download location in
debian/copyright to one that works.
 

Show All