Rev 9 | Rev 33 | Go to most recent revision | Only display areas with differences | Regard whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 9 | Rev 13 | ||
---|---|---|---|
1 | #!/usr/bin/make -f |
1 | #!/usr/bin/make -f |
2 | # debian/rules file for libraries |
2 | # debian/rules file for libraries |
3 | # |
3 | # |
4 | # To build the packages, run `dpkg-buildpackage' or `debuild' from the |
4 | # To build the packages, run `dpkg-buildpackage' or `debuild' from the |
5 | # parent directory of this file. (You may need to specify the `-rfakeroot' |
5 | # parent directory of this file. (You may need to specify the `-rfakeroot' |
6 | # option if you are using dpkg-buildpackage and are not running as root) |
6 | # option if you are using dpkg-buildpackage and are not running as root) |
7 | # |
7 | # |
8 | # $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $ |
8 | # $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $ |
9 | # |
9 | # |
10 | # Copyright (C) 1999, 2000, 2001, 2002 Timshel Knoll <timshel@debian.org> |
10 | # Copyright (C) 1999, 2000, 2001, 2002 Timshel Knoll <timshel@debian.org> |
11 | # Licensed under the terms of the GNU General Public License |
11 | # Licensed under the terms of the GNU General Public License |
12 | # |
12 | # |
13 | # Based originally on Sample debian/rules that uses debhelper, from dh-make, |
13 | # Based originally on Sample debian/rules that uses debhelper, from dh-make, |
14 | # GNU copyright 1997 to 1999 by Joey Hess. |
14 | # GNU copyright 1997 to 1999 by Joey Hess. |
15 | 15 | ||
16 | # Uncomment this to turn on verbose mode. |
16 | # Uncomment this to turn on verbose mode. |
17 | #export DH_VERBOSE=1 |
17 | #export DH_VERBOSE=1 |
18 | 18 | ||
19 | include /usr/share/dpatch/dpatch.make |
- | |
20 | - | ||
21 | # These are used for cross-compiling and for saving the configure script |
19 | # These are used for cross-compiling and for saving the configure script |
22 | # from having to guess our platform (since we know it already) |
20 | # from having to guess our platform (since we know it already) |
23 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
21 | DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
24 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
22 | DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
25 | 23 | ||
26 | 24 | ||
27 | CFLAGS += -g |
25 | CFLAGS += -g |
28 | ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS))) |
26 | ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS))) |
29 | CFLAGS += -O2 |
27 | CFLAGS += -O2 |
30 | else |
28 | else |
31 | CFLAGS += -O0 |
29 | CFLAGS += -O0 |
32 | endif |
30 | endif |
33 | 31 | ||
34 | 32 | ||
35 | # The name of the library - this is the base name of the packages that |
33 | # The name of the library - this is the base name of the packages that |
36 | # will be built |
34 | # will be built |
37 | LIBRARY = liboop |
35 | LIBRARY = liboop |
38 | 36 | ||
39 | # This is the soname of the package being built - we have to know this |
37 | # This is the soname of the package being built - we have to know this |
40 | # before the start of the build because changing the control file half |
38 | # before the start of the build because changing the control file half |
41 | # way though the build probably isn't a good idea, and this would also |
39 | # way though the build probably isn't a good idea, and this would also |
42 | # mean renaming the $(LIBRARY)$(SONAME).{files,docs,...} files |
40 | # mean renaming the $(LIBRARY)$(SONAME).{files,docs,...} files |
43 | SONAME = 4 |
41 | SONAME = 4 |
44 | 42 | ||
45 | # A list of variables to substitute when generating files from .in files |
43 | # A list of variables to substitute when generating files from .in files |
46 | # If you put an 'x' here, then all @x@'s in .in files will be substituted |
44 | # If you put an 'x' here, then all @x@'s in .in files will be substituted |
47 | # with the value of $(x) in the output file |
45 | # with the value of $(x) in the output file |
48 | SUBSTS = SONAME |
46 | SUBSTS = SONAME |
49 | 47 | ||
50 | GENFILES = debian/control \ |
48 | GENFILES = debian/control \ |
51 | debian/$(LIBRARY)$(SONAME).files \ |
49 | debian/$(LIBRARY)$(SONAME).files \ |
52 | debian/$(LIBRARY)$(SONAME).dirs |
50 | debian/$(LIBRARY)$(SONAME).dirs |
53 | 51 | ||
54 | # We can't use these until after the package has been built ... otherwise |
52 | # We can't use these until after the package has been built ... otherwise |
55 | # they will fail because no .libs/lib*.so.* exists |
53 | # they will fail because no .libs/lib*.so.* exists |
56 | version = $(shell ls .libs/lib*.so.* | \ |
54 | version = $(shell ls .libs/lib*.so.* | \ |
57 | awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) \ |
55 | awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) \ |
58 | print substr($$0,RSTART)}') |
56 | print substr($$0,RSTART)}') |
59 | major = $(shell ls .libs/lib*.so.* | \ |
57 | major = $(shell ls .libs/lib*.so.* | \ |
60 | awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}') |
58 | awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}') |
61 | 59 | ||
62 | # This builds a substitution list for sed based on the SUBSTS variable |
60 | # This builds a substitution list for sed based on the SUBSTS variable |
63 | # and the variables whose names SUBSTS contains ... |
61 | # and the variables whose names SUBSTS contains ... |
64 | SUBSTLIST = $(foreach subst, $(SUBSTS),s/@$(subst)@/$($(subst))/g;) |
62 | SUBSTLIST = $(foreach subst, $(SUBSTS),s/@$(subst)@/$($(subst))/g;) |
65 | 63 | ||
66 | # A sane default rule |
64 | # A sane default rule |
67 | default: |
65 | default: |
68 | @echo "Try: debian/rules [configure|build|clean|install|binary|binary-arch|binary-indep]" |
66 | @echo "Try: debian/rules [configure|build|clean|install|binary|binary-arch|binary-indep]" |
69 | @echo "Vars:" |
67 | @echo "Vars:" |
70 | @echo " SUBSTLIST: $(SUBSTLIST)" |
68 | @echo " SUBSTLIST: $(SUBSTLIST)" |
71 | @echo " SONAME: $(SONAME)" |
69 | @echo " SONAME: $(SONAME)" |
72 | 70 | ||
73 | # Pattern rules: |
71 | # Pattern rules: |
74 | 72 | ||
75 | # How to generate files from .in's |
73 | # How to generate files from .in's |
76 | debian/%: debian/%.in debian/rules |
74 | debian/%: debian/%.in debian/rules |
77 | sed -e '$(SUBSTLIST)' < $< > $@ |
75 | sed -e '$(SUBSTLIST)' < $< > $@ |
78 | 76 | ||
79 | # This puts the $(LIBRARY)* packaging files in their right places |
77 | # This puts the $(LIBRARY)* packaging files in their right places |
80 | # Could I / should I use ln? |
78 | # Could I / should I use ln? |
81 | debian/$(LIBRARY)$(SONAME).%: debian/$(LIBRARY).% |
79 | debian/$(LIBRARY)$(SONAME).%: debian/$(LIBRARY).% |
82 | cp $< $@ |
80 | cp $< $@ |
83 | 81 | ||
84 | # Do the substitution/moving stuff |
82 | # Do the substitution/moving stuff |
85 | packaging-files: $(GENFILES) |
83 | packaging-files: $(GENFILES) |
86 | 84 | ||
87 | configure: packaging-files configure-stamp |
85 | configure: packaging-files configure-stamp |
88 | configure-stamp: $(DPATCH_STAMPFN) |
86 | configure-stamp: |
89 | dh_testdir |
87 | dh_testdir |
90 | 88 | ||
- | 89 | autoreconf -sfi |
|
- | 90 | ||
91 | env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
91 | env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \ |
92 | --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr |
92 | --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr |
93 | 93 | ||
94 | touch $@ |
94 | touch $@ |
95 | 95 | ||
96 | build: configure-stamp build-stamp |
96 | build: configure-stamp build-stamp |
97 | build-stamp: |
97 | build-stamp: |
98 | dh_testdir |
98 | dh_testdir |
99 | 99 | ||
100 | $(MAKE) |
100 | $(MAKE) |
101 | 101 | ||
102 | touch $@ |
102 | touch $@ |
103 | 103 | ||
104 | clean: clean-patched unpatch |
104 | clean: |
105 | dh_testdir |
105 | dh_testdir |
106 | dh_testroot |
106 | dh_testroot |
107 | rm -f build-stamp configure-stamp |
107 | rm -f build-stamp configure-stamp |
108 | 108 | ||
109 | [ ! -f Makefile ] || $(MAKE) distclean |
109 | [ ! -f Makefile ] || $(MAKE) distclean |
110 | [ ! -f liboop.org/Makefile ] || $(MAKE) -C liboop.org distclean |
110 | $(MAKE) -C liboop.org distclean |
111 | 111 | ||
- | 112 | rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh |
|
112 | dh_clean |
113 | dh_clean |
113 | 114 | ||
114 | install-indep: |
115 | install-indep: |
115 | dh_testdir |
116 | dh_testdir |
116 | dh_testroot |
117 | dh_testroot |
117 | dh_clean -k |
118 | dh_clean -k |
118 | dh_installdirs -i |
119 | dh_installdirs -i |
119 | 120 | ||
120 | $(MAKE) -C liboop.org install \ |
121 | $(MAKE) -C liboop.org install \ |
121 | DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html |
122 | DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html |
122 | 123 | ||
123 | install-arch: build |
124 | install-arch: build |
124 | dh_testdir |
125 | dh_testdir |
125 | dh_testroot |
126 | dh_testroot |
126 | dh_clean -k |
127 | dh_clean -k |
127 | dh_installdirs -a |
128 | dh_installdirs -a |
128 | 129 | ||
129 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
130 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
130 | 131 | ||
131 | binary-indep: install-indep |
132 | binary-indep: install-indep |
132 | dh_testdir |
133 | dh_testdir |
133 | dh_testroot |
134 | dh_testroot |
134 | dh_movefiles -i |
135 | dh_movefiles -i |
135 | 136 | ||
136 | dh_installdocs -i |
137 | dh_installdocs -i |
137 | dh_installman -i |
138 | dh_installman -i |
138 | dh_installinfo -i |
139 | dh_installinfo -i |
139 | dh_installchangelogs -i |
140 | dh_installchangelogs -i |
140 | dh_link -i |
141 | dh_link -i |
141 | dh_compress -i -Xliboop-doc/html |
142 | dh_compress -i -Xliboop-doc/html |
142 | dh_fixperms -i |
143 | dh_fixperms -i |
143 | dh_installdeb -i |
144 | dh_installdeb -i |
144 | dh_gencontrol -i |
145 | dh_gencontrol -i |
145 | dh_md5sums -i |
146 | dh_md5sums -i |
146 | dh_builddeb -i |
147 | dh_builddeb -i |
147 | 148 | ||
148 | binary-arch: install-arch |
149 | binary-arch: install-arch |
149 | dh_testdir |
150 | dh_testdir |
150 | dh_testroot |
151 | dh_testroot |
151 | dh_movefiles -a |
152 | dh_movefiles -a |
152 | 153 | ||
153 | dh_installdocs -a |
154 | dh_installdocs -a |
154 | dh_installman -a |
155 | dh_installman -a |
155 | dh_installinfo -a |
156 | dh_installinfo -a |
156 | dh_installchangelogs -a |
157 | dh_installchangelogs -a |
157 | dh_link -a |
158 | dh_link -a |
158 | dh_strip -a |
159 | dh_strip -a |
159 | dh_compress -a -Xliboop-doc/html |
160 | dh_compress -a -Xliboop-doc/html |
160 | dh_fixperms -a |
161 | dh_fixperms -a |
161 | dh_makeshlibs -a |
162 | dh_makeshlibs -a |
162 | dh_installdeb -a |
163 | dh_installdeb -a |
163 | # Don't add the depends for adapter libraries - programs which link |
164 | # Don't add the depends for adapter libraries - programs which link |
164 | # with them will also link with the appropriate library |
165 | # with them will also link with the appropriate library |
165 | dh_shlibdeps -a -Xliboop- |
166 | dh_shlibdeps -a -Xliboop- |
166 | dh_gencontrol -a |
167 | dh_gencontrol -a |
167 | dh_md5sums -a |
168 | dh_md5sums -a |
168 | dh_builddeb -a |
169 | dh_builddeb -a |
169 | 170 | ||
170 | binary: binary-indep binary-arch |
171 | binary: binary-indep binary-arch |
171 | 172 | ||
172 | .PHONY: packaging-files configure build install |
173 | .PHONY: packaging-files configure build install |
173 | .PHONY: binary-indep binary-arch binary clean |
174 | .PHONY: binary-indep binary-arch binary clean |