Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 26 | Rev 34 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules file for libraries
3
#
4
# To build the packages, run `dpkg-buildpackage' or `debuild' from the
5
# parent directory of this file. (You may need to specify the `-rfakeroot'
6
# option if you are using dpkg-buildpackage and are not running as root)
7
#
8
# $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $
9
#
10
# Copyright (C) 1999, 2000, 2001, 2002  Timshel Knoll <timshel@debian.org>
11
# Licensed under the terms of the GNU General Public License
12
#
13
# Based originally on Sample debian/rules that uses debhelper, from dh-make,
14
# GNU copyright 1997 to 1999 by Joey Hess.
15
 
16
# Uncomment this to turn on verbose mode.
17
#export DH_VERBOSE=1
18
 
19
# These are used for cross-compiling and for saving the configure script
20
# from having to guess our platform (since we know it already)
21
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
 
24
 
25
CFLAGS += -g
26
ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS)))
27
	CFLAGS += -O2
28
else
29
	CFLAGS += -O0
30
endif
31
 
32
 
33
# The name of the library - this is the base name of the packages that
34
# will be built
35
LIBRARY = liboop
36
 
37
# This is the soname of the package being built - we have to know this
38
# before the start of the build because changing the control file half
39
# way though the build probably isn't a good idea, and this would also
40
# mean renaming the $(LIBRARY)$(SONAME).{files,docs,...} files
41
SONAME = 4
42
 
43
# A list of variables to substitute when generating files from .in files
44
# If you put an 'x' here, then all @x@'s in .in files will be substituted
45
# with the value of $(x) in the output file
46
SUBSTS = SONAME
47
 
48
GENFILES = debian/control \
49
	debian/$(LIBRARY)$(SONAME).files \
50
	debian/$(LIBRARY)$(SONAME).dirs
51
 
52
# We can't use these until after the package has been built ... otherwise
53
# they will fail because no .libs/lib*.so.* exists
54
version = $(shell ls .libs/lib*.so.* | \
55
	    awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) \
56
	         print substr($$0,RSTART)}')
57
major = $(shell ls .libs/lib*.so.* | \
58
	  awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}')
59
 
60
# This builds a substitution list for sed based on the SUBSTS variable
61
# and the variables whose names SUBSTS contains ...
62
SUBSTLIST = $(foreach subst, $(SUBSTS),s/@$(subst)@/$($(subst))/g;)
63
 
64
# A sane default rule
65
default:
66
	@echo "Try: debian/rules [configure|build|clean|install|binary|binary-arch|binary-indep]"
67
	@echo "Vars:"
68
	@echo "	SUBSTLIST:	$(SUBSTLIST)"
69
	@echo "	SONAME:		$(SONAME)"
70
 
71
# Pattern rules:
72
 
73
# How to generate files from .in's
74
debian/%: debian/%.in debian/rules
75
	sed -e '$(SUBSTLIST)' < $< > $@
76
 
77
# This puts the $(LIBRARY)* packaging files in their right places
78
# Could I / should I use ln?
79
debian/$(LIBRARY)$(SONAME).%: debian/$(LIBRARY).%
80
	cp $< $@
81
 
82
# Do the substitution/moving stuff
83
packaging-files: $(GENFILES)
84
 
85
configure: packaging-files configure-stamp
13 magnus 86
configure-stamp:
3 magnus 87
	dh_testdir
88
 
13 magnus 89
	autoreconf -sfi
90
 
3 magnus 91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
93
 
94
	touch $@
95
 
96
build: configure-stamp build-stamp
97
build-stamp:
98
	dh_testdir
99
 
100
	$(MAKE)
101
 
102
	touch $@
103
 
13 magnus 104
clean:
3 magnus 105
	dh_testdir
106
	dh_testroot
107
	rm -f build-stamp configure-stamp
108
 
8 magnus 109
	[ ! -f Makefile ] || $(MAKE) distclean
13 magnus 110
	$(MAKE) -C liboop.org distclean
3 magnus 111
 
13 magnus 112
	rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh
3 magnus 113
	dh_clean
114
 
5 magnus 115
install-indep:
3 magnus 116
	dh_testdir
117
	dh_testroot
118
	dh_clean -k
119
 
120
	$(MAKE) -C liboop.org install \
121
		DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html
122
 
5 magnus 123
install-arch: build
4 magnus 124
	dh_testdir
125
	dh_testroot
5 magnus 126
	dh_clean -k
127
 
128
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
129
 
130
binary-indep: install-indep
131
	dh_testdir
132
	dh_testroot
4 magnus 133
	dh_movefiles -i
3 magnus 134
 
4 magnus 135
	dh_installdocs -i
136
	dh_installman -i
137
	dh_installinfo -i
138
	dh_installchangelogs -i
139
	dh_link -i
140
	dh_compress -i -Xliboop-doc/html
141
	dh_fixperms -i
142
	dh_installdeb -i
143
	dh_gencontrol -i
144
	dh_md5sums -i
145
	dh_builddeb -i
146
 
5 magnus 147
binary-arch: install-arch
3 magnus 148
	dh_testdir
149
	dh_testroot
4 magnus 150
	dh_movefiles -a
3 magnus 151
 
4 magnus 152
	dh_installdocs -a
153
	dh_installman -a
154
	dh_installinfo -a
155
	dh_installchangelogs -a
156
	dh_link -a
33 magnus 157
	dh_strip -a --dbg-package=liboop-dbg
4 magnus 158
	dh_compress -a -Xliboop-doc/html
159
	dh_fixperms -a
160
	dh_makeshlibs -a
161
	dh_installdeb -a
3 magnus 162
#	 Don't add the depends for adapter libraries - programs which link
163
#	 with them will also link with the appropriate library
4 magnus 164
	dh_shlibdeps -a -Xliboop-
165
	dh_gencontrol -a
166
	dh_md5sums -a
167
	dh_builddeb -a
3 magnus 168
 
169
binary: binary-indep binary-arch
170
 
171
.PHONY: packaging-files configure build install
172
.PHONY: binary-indep binary-arch binary clean