Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 4 | Rev 6 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/usr/bin/make -f
2
# debian/rules file for libraries
3
#
4
# To build the packages, run `dpkg-buildpackage' or `debuild' from the
5
# parent directory of this file. (You may need to specify the `-rfakeroot'
6
# option if you are using dpkg-buildpackage and are not running as root)
7
#
8
# $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $
9
#
10
# Copyright (C) 1999, 2000, 2001, 2002  Timshel Knoll <timshel@debian.org>
11
# Licensed under the terms of the GNU General Public License
12
#
13
# Based originally on Sample debian/rules that uses debhelper, from dh-make,
14
# GNU copyright 1997 to 1999 by Joey Hess.
15
 
16
# Uncomment this to turn on verbose mode.
17
#export DH_VERBOSE=1
18
 
19
# This is the debhelper compatibility version to use.
20
export DH_COMPAT=4
21
 
22
# These are used for cross-compiling and for saving the configure script
23
# from having to guess our platform (since we know it already)
24
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
25
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
26
 
27
 
28
CFLAGS += -g
29
ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS)))
30
	CFLAGS += -O2
31
else
32
	CFLAGS += -O0
33
endif
34
 
35
 
36
# The name of the library - this is the base name of the packages that
37
# will be built
38
LIBRARY = liboop
39
 
40
# This is the soname of the package being built - we have to know this
41
# before the start of the build because changing the control file half
42
# way though the build probably isn't a good idea, and this would also
43
# mean renaming the $(LIBRARY)$(SONAME).{files,docs,...} files
44
SONAME = 4
45
 
46
# A list of variables to substitute when generating files from .in files
47
# If you put an 'x' here, then all @x@'s in .in files will be substituted
48
# with the value of $(x) in the output file
49
SUBSTS = SONAME
50
 
51
GENFILES = debian/control \
52
	debian/$(LIBRARY)$(SONAME).files \
53
	debian/$(LIBRARY)$(SONAME).dirs
54
 
55
# We can't use these until after the package has been built ... otherwise
56
# they will fail because no .libs/lib*.so.* exists
57
version = $(shell ls .libs/lib*.so.* | \
58
	    awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) \
59
	         print substr($$0,RSTART)}')
60
major = $(shell ls .libs/lib*.so.* | \
61
	  awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}')
62
 
63
# This builds a substitution list for sed based on the SUBSTS variable
64
# and the variables whose names SUBSTS contains ...
65
SUBSTLIST = $(foreach subst, $(SUBSTS),s/@$(subst)@/$($(subst))/g;)
66
 
67
# A sane default rule
68
default:
69
	@echo "Try: debian/rules [configure|build|clean|install|binary|binary-arch|binary-indep]"
70
	@echo "Vars:"
71
	@echo "	SUBSTLIST:	$(SUBSTLIST)"
72
	@echo "	SONAME:		$(SONAME)"
73
 
74
# Pattern rules:
75
 
76
# How to generate files from .in's
77
debian/%: debian/%.in debian/rules
78
	sed -e '$(SUBSTLIST)' < $< > $@
79
 
80
# This puts the $(LIBRARY)* packaging files in their right places
81
# Could I / should I use ln?
82
debian/$(LIBRARY)$(SONAME).%: debian/$(LIBRARY).%
83
	cp $< $@
84
 
85
# Do the substitution/moving stuff
86
packaging-files: $(GENFILES)
87
 
88
configure: packaging-files configure-stamp
89
configure-stamp:
90
	dh_testdir
91
 
92
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
93
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
94
 
95
	touch $@
96
 
97
build: configure-stamp build-stamp
98
build-stamp:
99
	dh_testdir
100
 
101
	$(MAKE)
102
 
103
	touch $@
104
 
105
clean:
106
	dh_testdir
107
	dh_testroot
108
	rm -f build-stamp configure-stamp
109
 
110
	-$(MAKE) distclean
111
	-$(MAKE) -C liboop.org distclean
112
 
113
	-test -r /usr/share/misc/config.sub && \
114
	   cp -f /usr/share/misc/config.sub config.sub
115
	-test -r /usr/share/misc/config.guess && \
116
	   cp -f /usr/share/misc/config.guess config.guess
117
 
118
	dh_clean
119
 
5 magnus 120
install-indep:
3 magnus 121
	dh_testdir
122
	dh_testroot
123
	dh_clean -k
5 magnus 124
	dh_installdirs -i
3 magnus 125
 
126
	$(MAKE) -C liboop.org install \
127
		DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html
128
 
5 magnus 129
install-arch: build
4 magnus 130
	dh_testdir
131
	dh_testroot
5 magnus 132
	dh_clean -k
133
	dh_installdirs -a
134
 
135
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
136
 
137
binary-indep: install-indep
138
	dh_testdir
139
	dh_testroot
4 magnus 140
	dh_movefiles -i
3 magnus 141
 
4 magnus 142
	dh_installdocs -i
143
	dh_installman -i
144
	dh_installinfo -i
145
	dh_installchangelogs -i
146
	dh_link -i
147
	dh_compress -i -Xliboop-doc/html
148
	dh_fixperms -i
149
	dh_installdeb -i
150
	dh_gencontrol -i
151
	dh_md5sums -i
152
	dh_builddeb -i
153
 
5 magnus 154
binary-arch: install-arch
3 magnus 155
	dh_testdir
156
	dh_testroot
4 magnus 157
	dh_movefiles -a
3 magnus 158
 
4 magnus 159
	dh_installdocs -a
160
	dh_installman -a
161
	dh_installinfo -a
162
	dh_installchangelogs -a
163
	dh_link -a
164
	dh_strip -a
165
	dh_compress -a -Xliboop-doc/html
166
	dh_fixperms -a
167
	dh_makeshlibs -a
168
	dh_installdeb -a
3 magnus 169
#	 Don't add the depends for adapter libraries - programs which link
170
#	 with them will also link with the appropriate library
4 magnus 171
	dh_shlibdeps -a -Xliboop-
172
	dh_gencontrol -a
173
	dh_md5sums -a
174
	dh_builddeb -a
3 magnus 175
 
176
binary: binary-indep binary-arch
177
 
178
.PHONY: packaging-files configure build install
179
.PHONY: binary-indep binary-arch binary clean