Rev 34 | Rev 42 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 34 | Rev 36 | ||
---|---|---|---|
Line 44... | Line 44... | ||
44 | # If you put an 'x' here, then all @x@'s in .in files will be substituted |
44 | # If you put an 'x' here, then all @x@'s in .in files will be substituted |
45 | # with the value of $(x) in the output file |
45 | # with the value of $(x) in the output file |
46 | SUBSTS = SONAME |
46 | SUBSTS = SONAME |
47 | 47 | ||
48 | GENFILES = debian/control \ |
48 | GENFILES = debian/control \ |
49 | debian/$(LIBRARY)$(SONAME).files \ |
49 | debian/$(LIBRARY)$(SONAME).install \ |
50 | debian/$(LIBRARY)$(SONAME).dirs |
50 | debian/$(LIBRARY)$(SONAME).dirs |
51 | 51 | ||
52 | # We can't use these until after the package has been built ... otherwise |
52 | # We can't use these until after the package has been built ... otherwise |
53 | # they will fail because no .libs/lib*.so.* exists |
53 | # they will fail because no .libs/lib*.so.* exists |
54 | version = $(shell ls .libs/lib*.so.* | \ |
54 | version = $(shell ls .libs/lib*.so.* | \ |
Line 105... | Line 105... | ||
105 | dh_testdir |
105 | dh_testdir |
106 | dh_testroot |
106 | dh_testroot |
107 | rm -f build-stamp configure-stamp |
107 | rm -f build-stamp configure-stamp |
108 | 108 | ||
109 | [ ! -f Makefile ] || $(MAKE) distclean |
109 | [ ! -f Makefile ] || $(MAKE) distclean |
110 | $(MAKE) -C web distclean |
- | |
111 | 110 | ||
112 | rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh |
111 | rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh |
113 | dh_clean |
112 | dh_clean |
114 | 113 | ||
115 | install-indep: |
114 | install: build |
116 | dh_testdir |
115 | dh_testdir |
117 | dh_testroot |
116 | dh_testroot |
118 | dh_clean -k |
117 | dh_prep |
119 | - | ||
120 | $(MAKE) -C web install \ |
- | |
121 | DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html |
- | |
122 | - | ||
123 | install-arch: build |
- | |
124 | dh_testdir |
- | |
125 | dh_testroot |
- | |
126 | dh_clean -k |
- | |
127 | 118 | ||
128 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
119 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
129 | 120 | ||
130 | binary-indep: install-indep |
121 | binary-indep: |
131 | dh_testdir |
122 | dh_testdir |
132 | dh_testroot |
123 | dh_testroot |
133 | dh_movefiles -i |
124 | dh_install -i |
134 | 125 | ||
135 | dh_installdocs -i |
126 | dh_installdocs -i |
136 | dh_installman -i |
127 | dh_installman -i |
137 | dh_installinfo -i |
128 | dh_installinfo -i |
138 | dh_installchangelogs -i |
129 | dh_installchangelogs -i |
Line 142... | Line 133... | ||
142 | dh_installdeb -i |
133 | dh_installdeb -i |
143 | dh_gencontrol -i |
134 | dh_gencontrol -i |
144 | dh_md5sums -i |
135 | dh_md5sums -i |
145 | dh_builddeb -i |
136 | dh_builddeb -i |
146 | 137 | ||
147 | binary-arch: install-arch |
138 | binary-arch: install |
148 | dh_testdir |
139 | dh_testdir |
149 | dh_testroot |
140 | dh_testroot |
150 | dh_movefiles -a |
141 | dh_install -a |
151 | 142 | ||
152 | dh_installdocs -a |
143 | dh_installdocs -a |
153 | dh_installman -a |
144 | dh_installman -a |
154 | dh_installinfo -a |
145 | dh_installinfo -a |
155 | dh_installchangelogs -a |
146 | dh_installchangelogs -a |