Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 9 | Rev 26 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 9 Rev 13
Line 14... Line 14...
14
# GNU copyright 1997 to 1999 by Joey Hess.
14
# GNU copyright 1997 to 1999 by Joey Hess.
15
15
16
# Uncomment this to turn on verbose mode.
16
# Uncomment this to turn on verbose mode.
17
#export DH_VERBOSE=1
17
#export DH_VERBOSE=1
18
18
19
include /usr/share/dpatch/dpatch.make
-
 
20
-
 
21
# These are used for cross-compiling and for saving the configure script
19
# These are used for cross-compiling and for saving the configure script
22
# from having to guess our platform (since we know it already)
20
# from having to guess our platform (since we know it already)
23
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
21
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
24
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
22
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
25
23
Line 83... Line 81...
83
81
84
# Do the substitution/moving stuff
82
# Do the substitution/moving stuff
85
packaging-files: $(GENFILES)
83
packaging-files: $(GENFILES)
86
84
87
configure: packaging-files configure-stamp
85
configure: packaging-files configure-stamp
88
configure-stamp: $(DPATCH_STAMPFN)
86
configure-stamp:
89
	dh_testdir
87
	dh_testdir
90
88
-
 
89
	autoreconf -sfi
-
 
90
91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
93
93
94
	touch $@
94
	touch $@
95
95
Line 99... Line 99...
99
99
100
	$(MAKE)
100
	$(MAKE)
101
101
102
	touch $@
102
	touch $@
103
103
104
clean: clean-patched unpatch
104
clean:
105
	dh_testdir
105
	dh_testdir
106
	dh_testroot
106
	dh_testroot
107
	rm -f build-stamp configure-stamp
107
	rm -f build-stamp configure-stamp
108
108
109
	[ ! -f Makefile ] || $(MAKE) distclean
109
	[ ! -f Makefile ] || $(MAKE) distclean
110
	[ ! -f liboop.org/Makefile ] || $(MAKE) -C liboop.org distclean
110
	$(MAKE) -C liboop.org distclean
111
111
-
 
112
	rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh
112
	dh_clean
113
	dh_clean
113
114
114
install-indep:
115
install-indep:
115
	dh_testdir
116
	dh_testdir
116
	dh_testroot
117
	dh_testroot