Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Rev 5 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 3 Rev 4
Line 126... Line 126...
126
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
126
	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
127
	$(MAKE) -C liboop.org install \
127
	$(MAKE) -C liboop.org install \
128
		DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html
128
		DESTDIR=$(CURDIR)/debian/tmp/usr/share/doc/liboop-doc/html
129
129
130
binary-indep:
130
binary-indep:
-
 
131
	dh_testdir
-
 
132
	dh_testroot
-
 
133
	dh_movefiles -i
-
 
134
-
 
135
	dh_installdocs -i
-
 
136
	dh_installman -i
-
 
137
	dh_installinfo -i
-
 
138
	dh_installchangelogs -i
-
 
139
	dh_link -i
-
 
140
	dh_compress -i -Xliboop-doc/html
-
 
141
	dh_fixperms -i
-
 
142
	dh_installdeb -i
-
 
143
	dh_gencontrol -i
-
 
144
	dh_md5sums -i
131
# Nothing to do
145
	dh_builddeb -i
132
146
133
binary-arch: build install
147
binary-arch: build install
134
	dh_testdir
148
	dh_testdir
135
	dh_testroot
149
	dh_testroot
136
	dh_movefiles
150
	dh_movefiles -a
137
151
138
	dh_installdocs
152
	dh_installdocs -a
139
	dh_installman
153
	dh_installman -a
140
	dh_installinfo
154
	dh_installinfo -a
141
	dh_installchangelogs
155
	dh_installchangelogs -a
142
	dh_link
156
	dh_link -a
143
	dh_strip
157
	dh_strip -a
144
	dh_compress -Xliboop-doc/html
158
	dh_compress -a -Xliboop-doc/html
145
	dh_fixperms
159
	dh_fixperms -a
146
	dh_makeshlibs
160
	dh_makeshlibs -a
147
	dh_installdeb
161
	dh_installdeb -a
148
#	 Don't add the depends for adapter libraries - programs which link
162
#	 Don't add the depends for adapter libraries - programs which link
149
#	 with them will also link with the appropriate library
163
#	 with them will also link with the appropriate library
150
	dh_shlibdeps -Xliboop-
164
	dh_shlibdeps -a -Xliboop-
151
	dh_gencontrol
165
	dh_gencontrol -a
152
	dh_md5sums
166
	dh_md5sums -a
153
	dh_builddeb
167
	dh_builddeb -a
154
168
155
binary: binary-indep binary-arch
169
binary: binary-indep binary-arch
156
170
157
.PHONY: packaging-files configure build install
171
.PHONY: packaging-files configure build install
158
.PHONY: binary-indep binary-arch binary clean
172
.PHONY: binary-indep binary-arch binary clean