Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 36 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 36 Rev 42
Line 1... Line 1...
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# debian/rules file for libraries
-
 
3
#
2
#
4
# To build the packages, run `dpkg-buildpackage' or `debuild' from the
3
# To build the packages, run `dpkg-buildpackage' or `debuild' from the
5
# parent directory of this file. (You may need to specify the `-rfakeroot'
4
# parent directory of this file. (You may need to specify the `-rfakeroot'
6
# option if you are using dpkg-buildpackage and are not running as root)
5
# option if you are using dpkg-buildpackage and are not running as root)
7
#
6
#
8
# $Id: rules,v 1.8 2003/04/30 07:45:50 timshel Exp $
-
 
9
#
-
 
10
# Copyright (C) 1999, 2000, 2001, 2002  Timshel Knoll <timshel@debian.org>
7
# Copyright (C) 1999, 2000, 2001, 2002  Timshel Knoll <timshel@debian.org>
11
# Licensed under the terms of the GNU General Public License
8
# Licensed under the terms of the GNU General Public License
12
#
9
#
13
# Based originally on Sample debian/rules that uses debhelper, from dh-make,
10
# Based originally on Sample debian/rules that uses debhelper, from dh-make,
14
# GNU copyright 1997 to 1999 by Joey Hess.
11
# GNU copyright 1997 to 1999 by Joey Hess.
Line 19... Line 16...
19
# These are used for cross-compiling and for saving the configure script
16
# These are used for cross-compiling and for saving the configure script
20
# from having to guess our platform (since we know it already)
17
# from having to guess our platform (since we know it already)
21
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18
DEB_HOST_GNU_TYPE       ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
DEB_BUILD_GNU_TYPE      ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
20
24
-
 
25
CFLAGS += -g
-
 
26
ifeq (, $(findstring noopt, $(DEB_BUILD_OPTIONS)))
21
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
27
	CFLAGS += -O2
22
  buildflags := --build=$(DEB_BUILD_GNU_TYPE)
28
else
23
else
29
	CFLAGS += -O0
24
  buildflags := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
30
endif
25
endif
31
26
-
 
27
buildflags += $(shell dpkg-buildflags --export=configure)
32
28
33
# The name of the library - this is the base name of the packages that
29
# The name of the library - this is the base name of the packages that
34
# will be built
30
# will be built
35
LIBRARY = liboop
31
LIBRARY = liboop
36
32
Line 84... Line 80...
84
80
85
configure: packaging-files configure-stamp
81
configure: packaging-files configure-stamp
86
configure-stamp:
82
configure-stamp:
87
	dh_testdir
83
	dh_testdir
88
84
89
	autoreconf -sfi
85
	[ -f debian/autoreconf.before ] || dh_autoreconf
90
86
91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
87
	./configure --prefix=/usr $(buildflags)
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
-
 
93
88
94
	touch $@
89
	touch $@
95
90
96
build: configure-stamp build-stamp
91
build: build-arch
97
build-stamp:
92
build-indep:
-
 
93
build-arch: build-stamp
-
 
94
build-stamp: configure-stamp
98
	dh_testdir
95
	dh_testdir
99
96
100
	$(MAKE)
97
	$(MAKE)
101
98
102
	touch $@
99
	touch $@
Line 106... Line 103...
106
	dh_testroot
103
	dh_testroot
107
	rm -f build-stamp configure-stamp
104
	rm -f build-stamp configure-stamp
108
105
109
	[ ! -f Makefile ] || $(MAKE) distclean
106
	[ ! -f Makefile ] || $(MAKE) distclean
110
107
111
	rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh
-
 
112
	dh_clean
108
	dh_autoreconf_clean
-
 
109
	dh_clean libtool configure
113
110
114
install: build
111
install: build
115
	dh_testdir
112
	dh_testdir
116
	dh_testroot
113
	dh_testroot
117
	dh_prep
114
	dh_prep