Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 8 | Rev 13 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 8 Rev 9
Line 83... Line 83...
83
83
84
# Do the substitution/moving stuff
84
# Do the substitution/moving stuff
85
packaging-files: $(GENFILES)
85
packaging-files: $(GENFILES)
86
86
87
configure: packaging-files configure-stamp
87
configure: packaging-files configure-stamp
88
configure-stamp:
88
configure-stamp: $(DPATCH_STAMPFN)
89
	dh_testdir
89
	dh_testdir
90
90
91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
91
	env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
92
		--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
93
93
Line 99... Line 99...
99
99
100
	$(MAKE)
100
	$(MAKE)
101
101
102
	touch $@
102
	touch $@
103
103
104
clean:
104
clean: clean-patched unpatch
105
	dh_testdir
105
	dh_testdir
106
	dh_testroot
106
	dh_testroot
107
	rm -f build-stamp configure-stamp
107
	rm -f build-stamp configure-stamp
108
108
109
	[ ! -f Makefile ] || $(MAKE) distclean
109
	[ ! -f Makefile ] || $(MAKE) distclean
110
	[ ! -f liboop.org/Makefile ] || $(MAKE) -C liboop.org distclean
110
	[ ! -f liboop.org/Makefile ] || $(MAKE) -C liboop.org distclean
111
111
112
	-test -r /usr/share/misc/config.sub && \
-
 
113
	   cp -f /usr/share/misc/config.sub config.sub
-
 
114
	-test -r /usr/share/misc/config.guess && \
-
 
115
	   cp -f /usr/share/misc/config.guess config.guess
-
 
116
-
 
117
	dh_clean
112
	dh_clean
118
113
119
install-indep:
114
install-indep:
120
	dh_testdir
115
	dh_testdir
121
	dh_testroot
116
	dh_testroot