Subversion Repositories liboop-bad

Compare Revisions

Ignore whitespace Rev 12 → Rev 13

/trunk/debian/rules
16,8 → 16,6
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
 
include /usr/share/dpatch/dpatch.make
 
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
85,9 → 83,11
packaging-files: $(GENFILES)
 
configure: packaging-files configure-stamp
configure-stamp: $(DPATCH_STAMPFN)
configure-stamp:
dh_testdir
 
autoreconf -sfi
 
env CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr
 
101,14 → 101,15
 
touch $@
 
clean: clean-patched unpatch
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
 
[ ! -f Makefile ] || $(MAKE) distclean
[ ! -f liboop.org/Makefile ] || $(MAKE) -C liboop.org distclean
$(MAKE) -C liboop.org distclean
 
rm -rf Makefile.in aclocal.m4 ltmain.sh configure mkinstalldirs config.sub config.guess autom4te.cache missing depcomp install-sh
dh_clean
 
install-indep: